summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharles Harris <charlesr.harris@gmail.com>2020-08-03 07:33:47 -0600
committerGitHub <noreply@github.com>2020-08-03 07:33:47 -0600
commit60a21a35210725520077f13200498e2bf3198029 (patch)
tree3be2c25c9a6c000becc4240d7d2d98f999645e8c
parent0f123387616a61cd72d74aa5ec5bb2044ca8d8d8 (diff)
parent2e1df6d89a0fdf7f2063bdf0bd2c388f607357e4 (diff)
downloadnumpy-60a21a35210725520077f13200498e2bf3198029.tar.gz
Merge pull request #16993 from mattip/setuptools
BLD: pin setuptools<49.2.0
-rw-r--r--.circleci/config.yml2
-rw-r--r--azure-pipelines.yml4
-rw-r--r--pyproject.toml2
-rw-r--r--test_requirements.txt2
-rwxr-xr-xtools/travis-before-install.sh2
5 files changed, 6 insertions, 6 deletions
diff --git a/.circleci/config.yml b/.circleci/config.yml
index c3d4352e8..2a986cba6 100644
--- a/.circleci/config.yml
+++ b/.circleci/config.yml
@@ -29,7 +29,7 @@ jobs:
name: build numpy
command: |
. venv/bin/activate
- pip install --upgrade pip setuptools
+ pip install --upgrade pip 'setuptools<49.2.0'
pip install cython
pip install .
pip install scipy
diff --git a/azure-pipelines.yml b/azure-pipelines.yml
index cdff56e1a..da57649b8 100644
--- a/azure-pipelines.yml
+++ b/azure-pipelines.yml
@@ -132,7 +132,7 @@ stages:
otool -L /usr/local/lib/libopenblas*
displayName: 'install pre-built openblas'
condition: eq(variables['USE_OPENBLAS'], '1')
- - script: python -m pip install --upgrade pip setuptools wheel
+ - script: python -m pip install --upgrade pip 'setuptools<49.2.0' wheel
displayName: 'Install tools'
- script: |
python -m pip install -r test_requirements.txt
@@ -247,7 +247,7 @@ stages:
displayName: 'add gcc 4.8'
- script: |
# python3 has no setuptools, so install one to get us going
- python3 -m pip install --user --upgrade pip setuptools!=49.2.0
+ python3 -m pip install --user --upgrade pip 'setuptools<49.2.0'
python3 -m pip install --user -r test_requirements.txt
CPPFLAGS='' CC=gcc-4.8 F77=gfortran-5 F90=gfortran-5 \
python3 runtests.py --debug-info --mode=full -- -rsx --junitxml=junit/test-results.xml
diff --git a/pyproject.toml b/pyproject.toml
index a54d0b379..3566cc683 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,7 +1,7 @@
[build-system]
# Minimum requirements for the build system to execute.
requires = [
- "setuptools!=49.2.0",
+ "setuptools<49.2.0",
"wheel",
"Cython>=0.29.21", # Note: keep in sync with tools/cythonize.py
]
diff --git a/test_requirements.txt b/test_requirements.txt
index a2edf9600..953162350 100644
--- a/test_requirements.txt
+++ b/test_requirements.txt
@@ -1,6 +1,6 @@
cython==0.29.21
wheel
-setuptools!=49.2.0
+setuptools<49.2.0
hypothesis==5.23.2
pytest==5.4.3
pytz==2020.1
diff --git a/tools/travis-before-install.sh b/tools/travis-before-install.sh
index 1446a8bad..b62d74f40 100755
--- a/tools/travis-before-install.sh
+++ b/tools/travis-before-install.sh
@@ -29,7 +29,7 @@ gcc --version
popd
-pip install --upgrade pip setuptools!=49.2.0 wheel
+pip install --upgrade pip 'setuptools<49.2.0' wheel
# 'setuptools', 'wheel' and 'cython' are build dependencies. This information
# is stored in pyproject.toml, but there is not yet a standard way to install