summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharles Harris <charlesr.harris@gmail.com>2019-12-06 11:26:04 -0800
committerGitHub <noreply@github.com>2019-12-06 11:26:04 -0800
commit9251c33ffe0fe384a1f7be64e299967846f0c50c (patch)
tree180324ca3edc89d113145c4cddaff522033ba841
parentabde0a775e19b9f84cb3930f065cdf07f94f8526 (diff)
parentf0efb2a80565795afbdb2fce6428c0e623f16048 (diff)
downloadnumpy-9251c33ffe0fe384a1f7be64e299967846f0c50c.tar.gz
Merge pull request #15043 from charris/Update-HOWTO_RELEASE
DOC: Update HOWTO_RELEASE.rst.txt
-rw-r--r--doc/HOWTO_RELEASE.rst.txt133
1 files changed, 69 insertions, 64 deletions
diff --git a/doc/HOWTO_RELEASE.rst.txt b/doc/HOWTO_RELEASE.rst.txt
index 53359f0a2..f0231293f 100644
--- a/doc/HOWTO_RELEASE.rst.txt
+++ b/doc/HOWTO_RELEASE.rst.txt
@@ -3,143 +3,147 @@ NumPy.
Current build and release info
==============================
-
The current info on building and releasing NumPy and SciPy is scattered in
several places. It should be summarized in one place, updated, and where
necessary described in more detail. The sections below list all places where
useful info can be found.
+
Source tree
-----------
-* INSTALL.rst.txt
-* release.sh
-* pavement.py
+- INSTALL.rst.txt
+- release.sh
+- pavement.py
+
NumPy Docs
----------
-* https://github.com/numpy/numpy/blob/master/doc/HOWTO_RELEASE.rst.txt
-* http://projects.scipy.org/numpy/wiki/MicrosoftToolchainSupport (dead link)
+- https://github.com/numpy/numpy/blob/master/doc/HOWTO_RELEASE.rst.txt
+- http://projects.scipy.org/numpy/wiki/MicrosoftToolchainSupport (dead link)
+
SciPy.org wiki
--------------
-* https://www.scipy.org/Installing_SciPy and links on that page.
-* http://new.scipy.org/building/windows.html (dead link)
+- https://www.scipy.org/Installing_SciPy and links on that page.
+- http://new.scipy.org/building/windows.html (dead link)
+
Doc wiki
--------
-* http://docs.scipy.org/numpy/docs/numpy-docs/user/install.rst/ (dead link)
+- http://docs.scipy.org/numpy/docs/numpy-docs/user/install.rst/ (dead link)
+
Release Scripts
---------------
-* https://github.com/numpy/numpy-vendor
+- https://github.com/numpy/numpy-vendor
+
Supported platforms and versions
================================
-
Python 2.7 and >=3.4 are the currently supported versions when building from
source. We test NumPy against all these versions every time we merge code to
master. Binary installers may be available for a subset of these versions (see
below).
+
OS X
----
-
Python 2.7 and >=3.4 are the versions for which we provide binary installers.
OS X versions >= 10.6 are supported. We build binary wheels for OSX that are
compatible with Python.org Python, system Python, homebrew and macports - see
this `OSX wheel building summary
<https://github.com/MacPython/wiki/wiki/Spinning-wheels>`_ for details.
+
Windows
-------
-
We build 32- and 64-bit wheels for Python 2.7, 3.4, 3.5 on Windows. Windows
XP, Vista, 7, 8 and 10 are supported. We build NumPy using the MSVC compilers
on Appveyor, but we are hoping to update to a `mingw-w64 toolchain
<https://mingwpy.github.io>`_. The Windows wheels use ATLAS for BLAS / LAPACK.
+
Linux
-----
-
We build and ship `manylinux1 <https://www.python.org/dev/peps/pep-0513>`_
wheels for NumPy. Many Linux distributions include their own binary builds
of NumPy.
+
BSD / Solaris
-------------
-
No binaries are provided, but successful builds on Solaris and BSD have been
reported.
+
Tool chain
==========
-
We build all our wheels on cloud infrastructure - so this list of compilers is
for information and debugging builds locally. See the ``.travis.yml`` and
``appveyor.yml`` scripts in the `numpy wheels`_ repo for the definitive source
of the build recipes. Packages that are available using pip are noted.
+
Compilers
---------
-
The same gcc version is used as the one with which Python itself is built on
each platform. At the moment this means:
-* OS X builds on travis currently use `clang`. It appears that binary wheels
+- OS X builds on travis currently use `clang`. It appears that binary wheels
for OSX >= 10.6 can be safely built from the travis-ci OSX 10.9 VMs
when building against the Python from the Python.org installers;
-* Windows builds use the MSVC version corresponding to the Python being built
+- Windows builds use the MSVC version corresponding to the Python being built
against;
-* Manylinux1 wheels use the gcc provided on the Manylinux docker images.
+- Manylinux1 wheels use the gcc provided on the Manylinux docker images.
You will need Cython for building the binaries. Cython compiles the ``.pyx``
files in the NumPy distribution to ``.c`` files.
+
Building source archives and wheels
-----------------------------------
-
You will need write permission for numpy-wheels in order to trigger wheel
builds.
-* Python(s) from `python.org <https://python.org>`_ or linux distro.
-* cython
-* virtualenv (pip)
-* Paver (pip)
-* numpy-wheels `<https://github.com/MacPython/numpy-wheels>`_ (clone)
+- Python(s) from `python.org <https://python.org>`_ or linux distro.
+- cython
+- virtualenv (pip)
+- Paver (pip)
+- numpy-wheels `<https://github.com/MacPython/numpy-wheels>`_ (clone)
+
Building docs
-------------
-
Building the documents requires a number of latex ``.sty`` files. Install them
all to avoid aggravation.
-* Sphinx (pip)
-* numpydoc (pip)
-* Matplotlib
-* Texlive (or MikTeX on Windows)
+- Sphinx (pip)
+- numpydoc (pip)
+- Matplotlib
+- Texlive (or MikTeX on Windows)
+
Uploading to PyPI
-----------------
+- terryfy `<https://github.com/MacPython/terryfy>`_ (clone).
+- beautifulsoup4 (pip)
+- delocate (pip)
+- auditwheel (pip)
+- twine (pip)
-* terryfy `<https://github.com/MacPython/terryfy>`_ (clone).
-* beautifulsoup4 (pip)
-* delocate (pip)
-* auditwheel (pip)
-* twine (pip)
Generating author/pr lists
--------------------------
-
You will need a personal access token
`<https://help.github.com/articles/creating-a-personal-access-token-for-the-command-line/>`_
so that scripts can access the github NumPy repository.
-* gitpython (pip)
-* pygithub (pip)
+- gitpython (pip)
+- pygithub (pip)
+
Virtualenv
----------
-
Virtualenv is a very useful tool to keep several versions of packages around.
It is also used in the Paver script to build the docs.
@@ -149,27 +153,28 @@ What is released
Wheels
------
+We currently support Python 3.6-3.8 on Windows, OSX, and Linux
-* Windows wheels for Python 2.7, 3.4, 3.5, for 32- and 64-bit, built using
- Appveyor;
-* Dual architecture OSX wheels built via travis-ci;
-* 32- and 64-bit Manylinux1 wheels built via travis-ci.
+* Windows: 32-bit and 64-bit wheels built using Appveyor;
+* OSX: x64_86 OSX wheels built using travis-ci;
+* Linux: 32-bit and 64-bit Manylinux1 wheels built using travis-ci.
See the `numpy wheels`_ building repository for more detail.
.. _numpy wheels : https://github.com/MacPython/numpy-wheels
+
Other
-----
+- Release Notes
+- Changelog
-* Release Notes
-* Changelog
Source distribution
-------------------
-
We build source releases in both .zip and .tar.gz formats.
+
Release process
===============
@@ -182,6 +187,7 @@ After a date is set, create a new maintenance/x.y.z branch, add new empty
release notes for the next version in the master branch and update the Trac
Milestones.
+
Make sure current branch builds a package correctly
---------------------------------------------------
::
@@ -197,6 +203,7 @@ best to read the pavement.py script.
.. note:: The following steps are repeated for the beta(s), release
candidates(s) and the final release.
+
Check deprecations
------------------
Before the release branch is made, it should be checked that all deprecated
@@ -244,6 +251,7 @@ There are three steps to the process.
The C ABI version number in numpy/core/setup_common.py should only be
updated for a major release.
+
Check the release notes
-----------------------
Use `towncrier`_ to build the release note and
@@ -268,6 +276,7 @@ following:
.. _towncrier: https://github.com/hawkowl/towncrier
+
Update the release status and create a release "tag"
----------------------------------------------------
Identify the commit hash of the release, e.g. 1b2e1d63ff.
@@ -325,12 +334,6 @@ to public keyservers, with a command such as::
gpg --send-keys <yourkeyid>
-Apply patch to fix bogus strides
---------------------------------
-NPY_RELAXED_STRIDE_CHECKING was made the default in NumPy 1.10.0 and bogus
-strides are used in the development branch to smoke out problems. The
-`patch <https://github.com/numpy/numpy/pull/5996>`_ should be updated if
-necessary and applied to the release branch to rationalize the strides.
Update the version of the master branch
---------------------------------------
@@ -340,15 +343,15 @@ Increment the release number in setup.py. Release candidates should have "rc1"
Also create a new version hash in cversions.txt and a corresponding version
define NPY_x_y_API_VERSION in numpyconfig.h
+
Trigger the wheel builds on travis-ci and Appveyor
--------------------------------------------------
-
See the `numpy wheels` repository.
In that repository edit the files:
-* ``.travis.yml``;
-* ``appveyor.yml``.
+- ``.travis.yml``;
+- ``appveyor.yml``.
In both cases, set the ``BUILD_COMMIT`` variable to the current release tag -
e.g. ``v1.11.1``.
@@ -365,19 +368,20 @@ Trigger a build by doing a commit of your edits to ``.travis.yml`` and
The wheels, once built, appear at a Rackspace container pointed at by:
-* http://wheels.scipy.org
-* https://3f23b170c54c2533c070-1c8a9b3114517dc5fe17b7c3f8c63a43.ssl.cf2.rackcdn.com
+- http://wheels.scipy.org
+- https://3f23b170c54c2533c070-1c8a9b3114517dc5fe17b7c3f8c63a43.ssl.cf2.rackcdn.com
The HTTP address may update first, and you should wait 15 minutes after the
build finishes before fetching the binaries.
+
Make the release
----------------
-
Build the changelog and notes for upload with::
paver write_release_and_log
+
Build and archive documentation
-------------------------------
Do::
@@ -397,9 +401,9 @@ create an archive of the documentation in the numpy/doc repo::
# Push to numpy/doc repo
git -C push
+
Update PyPI
-----------
-
The wheels and source should be uploaded to PyPI.
You should upload the wheels first, and the source formats last, to make sure
@@ -436,9 +440,9 @@ interface.
.. _push-tag-and-commit:
+
Push the release tag and commit
-------------------------------
-
Finally, now you are confident this tag correctly defines the source code that
you released you can push the tag and release commit up to github::
@@ -448,18 +452,18 @@ you released you can push the tag and release commit up to github::
where ``upstream`` points to the main https://github.com/numpy/numpy.git
repository.
+
Update scipy.org
----------------
-
A release announcement with a link to the download site should be placed in the
sidebar of the front page of scipy.org.
The scipy.org should be a PR at https://github.com/scipy/scipy.org. The file
that needs modification is ``www/index.rst``. Search for ``News``.
+
Announce to the lists
---------------------
-
The release should be announced on the mailing lists of
NumPy and SciPy, to python-announce, and possibly also those of
Matplotlib, IPython and/or Pygame.
@@ -468,12 +472,13 @@ During the beta/RC phase, an explicit request for testing the binaries with
several other libraries (SciPy/Matplotlib/Pygame) should be posted on the
mailing list.
+
Announce to Linux Weekly News
-----------------------------
-
Email the editor of LWN to let them know of the release. Directions at:
https://lwn.net/op/FAQ.lwn#contact
+
After the final release
-----------------------
After the final release is announced, a few administrative tasks are left to be