summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharles Harris <charlesr.harris@gmail.com>2021-01-27 16:34:15 -0700
committerGitHub <noreply@github.com>2021-01-27 16:34:15 -0700
commit11a8f8d7dba0eb7b0bc31f74bec659e2e497abfd (patch)
treec1fa3db02b3a64623a4d7a1e2f63d3242e2061d5
parentfd996225c5f712e7fc4e301c6e698a8a10854dd9 (diff)
parent491d26b2bcbc3b1c57c3310d8a81f694c3450da3 (diff)
downloadnumpy-11a8f8d7dba0eb7b0bc31f74bec659e2e497abfd.tar.gz
Merge pull request #18245 from rgommers/fix-bdistegg
BLD: fix issue with `bdist_egg`, which made `make dist` in doc/ fail
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 6033916c2..4c7d825df 100755
--- a/setup.py
+++ b/setup.py
@@ -257,7 +257,8 @@ def parse_setuppy_commands():
# below and not standalone. Hence they're not added to good_commands.
good_commands = ('develop', 'sdist', 'build', 'build_ext', 'build_py',
'build_clib', 'build_scripts', 'bdist_wheel', 'bdist_rpm',
- 'bdist_wininst', 'bdist_msi', 'bdist_mpkg', 'build_src',)
+ 'bdist_wininst', 'bdist_msi', 'bdist_mpkg', 'build_src',
+ 'bdist_egg')
for command in good_commands:
if command in args: