summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Picus <matti.picus@gmail.com>2020-11-03 15:24:22 +0200
committerGitHub <noreply@github.com>2020-11-03 15:24:22 +0200
commit9dca4085c724b3e62d54dee33e42ebdba3bb975c (patch)
tree72e79c6332956cea2203759d680c7143dcf1c9ae
parent671e8a02aeed0e823e9380557cad3c20ba30a3cb (diff)
parent779d306fb6d851e7948bf6a97f4d2034db7d6f25 (diff)
downloadnumpy-9dca4085c724b3e62d54dee33e42ebdba3bb975c.tar.gz
Merge pull request #17700 from Qiyu8/fix-typos
Fix small typos.
-rw-r--r--numpy/core/src/common/npy_cpu_dispatch.h12
-rwxr-xr-xsetup.py2
2 files changed, 7 insertions, 7 deletions
diff --git a/numpy/core/src/common/npy_cpu_dispatch.h b/numpy/core/src/common/npy_cpu_dispatch.h
index 274520852..a0f82fa3d 100644
--- a/numpy/core/src/common/npy_cpu_dispatch.h
+++ b/numpy/core/src/common/npy_cpu_dispatch.h
@@ -17,7 +17,7 @@
* NumPy module's attributes `__cpu_baseline__` and `__cpu_dispaٍtch__`.
*/
/**
- * Note: Always gaurd the genreated headers within 'NPY_DISABLE_OPTIMIZATION',
+ * Note: Always guard the generated headers within 'NPY_DISABLE_OPTIMIZATION',
* due the nature of command argument '--disable-optimization',
* which is explicitly disabling the module ccompiler_opt.
*/
@@ -29,7 +29,7 @@
* It's better anyway to take them off and use built-in types(__vector, __pixel, __bool) instead,
* since c99 supports bool variables which may lead to ambiguous errors.
*/
- // backup 'bool' before including '_cpu_dispatch.h', since it may not defiend as a compiler token.
+ // backup 'bool' before including '_cpu_dispatch.h', since it may not defined as a compiler token.
#define NPY__DISPATCH_DEFBOOL
typedef bool npy__dispatch_bkbool;
#endif
@@ -134,10 +134,10 @@
* NPY_CPU_DISPATCH_DECLARE(void dispatch_me, (const int*, int*))
* NPY_CPU_DISPATCH_DECLARE(extern cb_type callback_tab, [TAB_SIZE])
*
- * By assuming the provided config header drived from a dispatch-able source,
+ * By assuming the provided config header derived from a dispatch-able source,
* that configured with "@targets baseline sse41 vsx3 asimdhp",
* they supported by the compiler and enabled via '--cpu-dspatch',
- * then the prototype declrations at the above example will equlivent to the follows:
+ * then the prototype declrations at the above example will equivalent to the follows:
*
* - x86:
* void dispatch_me(const int*, int*); // baseline
@@ -179,7 +179,7 @@
/**
* Macro NPY_CPU_DISPATCH_DECLARE_XB(LEFT, ...)
*
- * Same as `NPY_CPU_DISPATCH_DECLARE` but exclude the baseline declration even
+ * Same as `NPY_CPU_DISPATCH_DECLARE` but exclude the baseline declaration even
* if it was provided within the configration statments.
*/
#define NPY_CPU_DISPATCH_DECLARE_XB(...) \
@@ -206,7 +206,7 @@
* In order to call or to assign the pointer of it from outside the dispatch-able source,
* you have to use this Macro as follows:
*
- * // bring the genreated config header of the dispatch-abel source
+ * // bring the generated config header of the dispatch-able source
* #ifndef NPY_DISABLE_OPTIMIZATION
* #include "dispatchable_source_name.dispatch.h"
* #endif
diff --git a/setup.py b/setup.py
index c64a5c491..6d7e90c6a 100755
--- a/setup.py
+++ b/setup.py
@@ -423,7 +423,7 @@ def get_docs_url():
if not ISRELEASED:
return "https://numpy.org/devdocs"
else:
- # For releaeses, this URL ends up on pypi.
+ # For releases, this URL ends up on pypi.
# By pinning the version, users looking at old PyPI releases can get
# to the associated docs easily.
return "https://numpy.org/doc/{}.{}".format(MAJOR, MINOR)