summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalf Gommers <ralf.gommers@googlemail.com>2016-01-27 21:33:12 +0100
committerCharles Harris <charlesr.harris@gmail.com>2016-01-27 14:47:51 -0700
commit2a079b2d39ea71938912528cbe9d679649bf77b9 (patch)
treebc43561f328bbfbf15c72deacafbd8da1e0be7d6
parentcc2b0495118e4855acfeaea3253abf449f3e91dd (diff)
downloadnumpy-2a079b2d39ea71938912528cbe9d679649bf77b9.tar.gz
TST: test installing from sdist on TravisCI.
-rw-r--r--.travis.yml2
-rwxr-xr-xtools/travis-test.sh15
2 files changed, 16 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index c14994d0d..ccb182816 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -62,6 +62,8 @@ matrix:
env: USE_WHEEL=1
- python: 3.5
env: USE_WHEEL=1
+ - python: 3.5
+ env: USE_SDIST=1
- python: 2.7
env:
- PYTHONOPTIMIZE=2
diff --git a/tools/travis-test.sh b/tools/travis-test.sh
index 3de1ca78d..6ed51ee91 100755
--- a/tools/travis-test.sh
+++ b/tools/travis-test.sh
@@ -71,7 +71,7 @@ setup_chroot()
# linux32 python setup.py build
# when travis updates to ubuntu 14.04
#
- # Numpy may not distinquish between 64 and 32 bit atlas in the
+ # Numpy may not distinguish between 64 and 32 bit ATLAS in the
# configuration stage.
DIR=$1
set -u
@@ -149,6 +149,19 @@ if [ -n "$USE_WHEEL" ] && [ $# -eq 0 ]; then
pip install nose
popd
run_test
+elif [ -n "$USE_SDIST" ] && [ $# -eq 0 ]; then
+ # use an up-to-date pip / setuptools inside the venv
+ $PIP install -U virtualenv
+ $PYTHON setup.py sdist
+ # Make another virtualenv to install into
+ virtualenv --python=`which $PYTHON` venv-for-wheel
+ . venv-for-wheel/bin/activate
+ # Move out of source directory to avoid finding local numpy
+ pushd dist
+ pip install numpy*
+ pip install nose
+ popd
+ run_test
elif [ -n "$USE_CHROOT" ] && [ $# -eq 0 ]; then
DIR=/chroot
setup_chroot $DIR