summaryrefslogtreecommitdiff
path: root/TODO
diff options
context:
space:
mode:
Diffstat (limited to 'TODO')
-rw-r--r--TODO8
1 files changed, 8 insertions, 0 deletions
diff --git a/TODO b/TODO
index a5ecd34..1c33b14 100644
--- a/TODO
+++ b/TODO
@@ -21,6 +21,7 @@ rename Failure and split into subclasses for Import and other, and make
it optionally include the name of the file being considered so that
Failure test logs can be more informative
+* result object needs to call plugins.report()
* plugin methods to add
@@ -38,12 +39,19 @@ OK (skipped=2)
** this can only be done in nose test runner
+* Legacy plugin manager
+ This approach won't work
+ Need a mapping in EntryPointPluginManager of entry point -> wrapper
+ Need to finish the LegacyPluginProxy wrapper
+
BUGS
fix commands module -- use Config.configure to configure
fix collector func -- configure, return loader.loadTestsFromNames()
+output capture not working in python setup.py test -- no plugins loaded?
+
--exclude doesn't seem to work? in some cases?
-- when run vs spine suite, makeTest seemingly was called on an object