summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
authorjpellerin <devnull@localhost>2010-11-11 09:31:32 -0500
committerjpellerin <devnull@localhost>2010-11-11 09:31:32 -0500
commitee1d84f528cb40740c7f357838e7974528231f59 (patch)
tree1c77706ad4f7af779b735b9a79eec167132b41fc /scripts
parent840138c696d0ae06770cef68aaf742dcf3d59ed2 (diff)
downloadnose-ee1d84f528cb40740c7f357838e7974528231f59.tar.gz
Updated tox doc task to build manpage and readme as well, fixed manpage vs sphinx 1.0 issues, updated some nose version strings and make mkrelease run tox and build versions for python 2 and 3
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/mkrelease.py15
1 files changed, 9 insertions, 6 deletions
diff --git a/scripts/mkrelease.py b/scripts/mkrelease.py
index 86b67e1..1c19f23 100755
--- a/scripts/mkrelease.py
+++ b/scripts/mkrelease.py
@@ -3,12 +3,13 @@
#
# create and upload a release
import os
-import nose
import sys
from commands import getstatusoutput
success = 0
+sys.path.insert(0, os.path.dirname(os.path.dirname(__file__)))
+import nose
version = nose.__version__
SIMULATE = 'exec' not in sys.argv
@@ -47,13 +48,12 @@ def main():
# remove dev tag from setup
runcmd('cp setup.cfg.release setup.cfg')
- # build included docs
- cd('doc')
- runcmd('make man readme html')
- cd('..')
+ # build included docs, run tests
+ runcmd('tox')
- # make the distribution
+ # make the distributions
runcmd('python setup.py sdist')
+ runcmd('python3.1 setup.py bdist_egg')
# upload docs and distribution
if 'NOSE_UPLOAD' in os.environ:
@@ -69,6 +69,9 @@ def main():
cmd = 'scp -C dist/nose-%(version)s.tar.gz %(upload)s' % cv
runcmd(cmd)
+ cmd = 'scp -C dist/nose-%(version)s.*egg %(upload)s' % cv
+ runcmd(cmd)
+
cmd = 'ssh %(host)s "mkdir -p %(versionpath)s"' % cv
runcmd(cmd)