summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
authorJason Pellerin <jpellerin@gmail.com>2009-05-02 16:33:30 -0400
committerJason Pellerin <jpellerin@gmail.com>2009-05-02 16:33:30 -0400
commit165d02416bcff46a2e5a3fdc0edfc529ac38088f (patch)
tree6285a488285d2dc0df26a251c5d0fb6d75d40c97 /scripts
parentdda7fc1323426a21faf1d3997c6b2dcb8fa0fc4e (diff)
downloadnose-165d02416bcff46a2e5a3fdc0edfc529ac38088f.tar.gz
Revised mkrelease to build in clone
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/mkrelease.py18
1 files changed, 15 insertions, 3 deletions
diff --git a/scripts/mkrelease.py b/scripts/mkrelease.py
index 534bf97..b5c4e84 100755
--- a/scripts/mkrelease.py
+++ b/scripts/mkrelease.py
@@ -42,16 +42,28 @@ def main():
runcmd("hg tag -m 'Tagged release %s' %s" %
(version, tag))
+ # clone a fresh copy
+ runcmd('hg clone -r %s . /tmp/nose_%s' % (tag, tag))
+
+ # build release in clone
+ cd('/tmp/nose_%s' % tag)
+
# remove dev tag from setup
runcmd('cp setup.cfg.release setup.cfg')
+ # build included docs
cd('doc')
- runcmd('make html')
+ runcmd('make man readme')
cd('..')
-
- # make sdist
+
+ # make the distribution
runcmd('python setup.py sdist')
+ # make the docs (don't want these included in sdist)
+ cd('doc')
+ runcmd('make html')
+ cd('..')
+
# upload docs and distribution
if 'NOSE_UPLOAD' in os.environ:
up = os.environ['NOSE_UPLOAD']