summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjpellerin <devnull@localhost>2010-11-11 09:31:32 -0500
committerjpellerin <devnull@localhost>2010-11-11 09:31:32 -0500
commitee1d84f528cb40740c7f357838e7974528231f59 (patch)
tree1c77706ad4f7af779b735b9a79eec167132b41fc
parent840138c696d0ae06770cef68aaf742dcf3d59ed2 (diff)
downloadnose-ee1d84f528cb40740c7f357838e7974528231f59.tar.gz
Updated tox doc task to build manpage and readme as well, fixed manpage vs sphinx 1.0 issues, updated some nose version strings and make mkrelease run tox and build versions for python 2 and 3
-rw-r--r--README.txt8
-rw-r--r--doc/manpage.py14
-rw-r--r--nose/commands.py4
-rw-r--r--nose/usage.txt8
-rw-r--r--nosetests.17
-rwxr-xr-xscripts/mkrelease.py15
-rw-r--r--tox.ini2
7 files changed, 38 insertions, 20 deletions
diff --git a/README.txt b/README.txt
index 79083ce..801d748 100644
--- a/README.txt
+++ b/README.txt
@@ -195,6 +195,14 @@ Options
in place of the current working directory, which is the default.
Others will be added to the list of tests to execute. [NOSE_WHERE]
+--py3where=PY3WHERE
+
+ Look for tests in this directory under Python 3.x. Functions the
+ same as 'where', but only applies if running under Python 3.x or
+ above. Note that, if present under 3.x, this option completely
+ replaces any directories specified with 'where', so the 'where'
+ option becomes ineffective. [NOSE_PY3WHERE]
+
-m=REGEX, --match=REGEX, --testmatch=REGEX
Files, directories, function names, and class names that match this
diff --git a/doc/manpage.py b/doc/manpage.py
index 656d26e..3d9ffae 100644
--- a/doc/manpage.py
+++ b/doc/manpage.py
@@ -322,14 +322,10 @@ class Translator(nodes.NodeVisitor):
pass
def visit_admonition(self, node, name):
- raise NotImplementedError, node.astext()
- self.body.append(self.starttag(node, 'div', CLASS=name))
- self.body.append('<p class="admonition-title">'
- + self.language.labels[name] + '</p>\n')
+ self.visit_block_quote(node)
def depart_admonition(self):
- raise NotImplementedError, node.astext()
- self.body.append('</div>\n')
+ self.depart_block_quote(None)
def visit_attention(self, node):
self.visit_admonition(node, 'attention')
@@ -996,6 +992,12 @@ class Translator(nodes.NodeVisitor):
def depart_tgroup(self, node):
pass
+ def visit_compound(self, node):
+ pass
+
+ def depart_compound(self, node):
+ pass
+
def visit_thead(self, node):
raise NotImplementedError, node.astext()
self.write_colspecs()
diff --git a/nose/commands.py b/nose/commands.py
index 40a328b..b819b38 100644
--- a/nose/commands.py
+++ b/nose/commands.py
@@ -52,7 +52,7 @@ section of your setup()::
setup(
# ...
- setup_requires=['nose>=0.11']
+ setup_requires=['nose>=1.0']
)
This will direct setuptools to download and activate nose during the setup
@@ -97,7 +97,7 @@ else:
"""create the member variables, but change hyphens to
underscores
"""
-
+
self.option_to_cmds = {}
for opt in self.__parser.option_list:
cmd_name = opt._long_opts[0][2:]
diff --git a/nose/usage.txt b/nose/usage.txt
index b3bcbd4..86caa2d 100644
--- a/nose/usage.txt
+++ b/nose/usage.txt
@@ -93,7 +93,7 @@ with the plugins keyword argument.
0.9 plugins
-----------
-nose 0.11 can use SOME plugins that were written for nose 0.9. The
+nose 1.0 can use SOME plugins that were written for nose 0.9. The
default plugin manager inserts a compatibility wrapper around 0.9
plugins that adapts the changed plugin api calls. However, plugins
that access nose internals are likely to fail, especially if they
@@ -104,7 +104,7 @@ longer passed to startTest and partly because it's likely that the
plugin is trying to find out if the test is an instance of a class
that no longer exists.
-0.10 plugins
-------------
+0.10 and 0.11 plugins
+---------------------
-All plugins written for nose 0.10 should work with nose 0.11.
+All plugins written for nose 0.10 and 0.11 should work with nose 1.0.
diff --git a/nosetests.1 b/nosetests.1
index c25efba..a00d637 100644
--- a/nosetests.1
+++ b/nosetests.1
@@ -171,6 +171,11 @@ Look for tests in this directory. May be specified multiple times. The first dir
.TP
+\fB\-\-py3where\fR\fR=PY3WHERE
+Look for tests in this directory under Python 3.x. Functions the same as \'where\', but only applies if running under Python 3.x or above. Note that, if present under 3.x, this option completely replaces any directories specified with \'where\', so the \'where\' option becomes ineffective. [NOSE_PY3WHERE]
+
+
+.TP
\fB\-m\fR\fR=REGEX\fR, \fB\-\-match\fR\fR=REGEX\fR, \fB\-\-testmatch\fR\fR=REGEX
Files, directories, function names, and class names that match this regular expression are considered tests. Default: (?:^|[b_./\-])[Tt]est [NOSE_TESTMATCH]
@@ -461,5 +466,5 @@ jpellerin+nose@gmail.com
.SH COPYRIGHT
LGPL
-.\" Generated by docutils manpage writer on 2010-03-04 18:10.
+.\" Generated by docutils manpage writer on 2010-11-11 09:28.
.\"
diff --git a/scripts/mkrelease.py b/scripts/mkrelease.py
index 86b67e1..1c19f23 100755
--- a/scripts/mkrelease.py
+++ b/scripts/mkrelease.py
@@ -3,12 +3,13 @@
#
# create and upload a release
import os
-import nose
import sys
from commands import getstatusoutput
success = 0
+sys.path.insert(0, os.path.dirname(os.path.dirname(__file__)))
+import nose
version = nose.__version__
SIMULATE = 'exec' not in sys.argv
@@ -47,13 +48,12 @@ def main():
# remove dev tag from setup
runcmd('cp setup.cfg.release setup.cfg')
- # build included docs
- cd('doc')
- runcmd('make man readme html')
- cd('..')
+ # build included docs, run tests
+ runcmd('tox')
- # make the distribution
+ # make the distributions
runcmd('python setup.py sdist')
+ runcmd('python3.1 setup.py bdist_egg')
# upload docs and distribution
if 'NOSE_UPLOAD' in os.environ:
@@ -69,6 +69,9 @@ def main():
cmd = 'scp -C dist/nose-%(version)s.tar.gz %(upload)s' % cv
runcmd(cmd)
+ cmd = 'scp -C dist/nose-%(version)s.*egg %(upload)s' % cv
+ runcmd(cmd)
+
cmd = 'ssh %(host)s "mkdir -p %(versionpath)s"' % cv
runcmd(cmd)
diff --git a/tox.ini b/tox.ini
index 2057a49..0946208 100644
--- a/tox.ini
+++ b/tox.ini
@@ -13,7 +13,7 @@ deps=sphinx>=1.0
commands=
##make clean
##make doctest
- make html
+ make man readme html
##make linkcheck
[testenv:jython]