summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Golovizin <ag@sologoc.com>2012-03-28 22:56:28 +0400
committerAndrey Golovizin <ag@sologoc.com>2012-03-28 22:59:22 +0400
commit12740cadf14414f0abbc7ef1b58a83e66e973988 (patch)
treeb1d60a8405a3dc90bb93133fb8c87e6d2ddc6b4c
parente4cd72356bec95517fbf20b0c29599e920c97827 (diff)
downloadnose-12740cadf14414f0abbc7ef1b58a83e66e973988.tar.gz
Add documentation on using python setup.py nosetests with 2to3.
-rw-r--r--doc/index.rst5
1 files changed, 5 insertions, 0 deletions
diff --git a/doc/index.rst b/doc/index.rst
index eeb1805..68d16eb 100644
--- a/doc/index.rst
+++ b/doc/index.rst
@@ -60,6 +60,11 @@ nose supports python3. Building from source on python3 requires
have distribute installed, ``python3 setup.py install`` will install
it via distribute's bootstrap script.
+Additionally, if your project is using `2to3
+<http://docs.python.org/library/2to3.html>`_, ``python3 setup.py nosetests``
+command will automatically convert your sources with 2to3 and then the
+tests with python 3.
+
.. warning ::
nose itself supports python 3, but many 3rd-party plugins do not!