summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Szakmeister <john@szakmeister.net>2015-04-04 05:46:00 -0400
committerJohn Szakmeister <john@szakmeister.net>2015-04-04 05:46:00 -0400
commitd22b74668fc79ef16050ed2526534848b2f16255 (patch)
tree541ec8a07b3b24ce59f38d132d5b60e686db0dc0
parent788eb6f63d0776ca45aa18a689fff852efcf5223 (diff)
downloadnose-d22b74668fc79ef16050ed2526534848b2f16255.tar.gz
Update version and generated files.
-rw-r--r--README.txt12
-rw-r--r--nosetests.19
-rw-r--r--setup.py2
3 files changed, 19 insertions, 4 deletions
diff --git a/README.txt b/README.txt
index 67586d6..2697b81 100644
--- a/README.txt
+++ b/README.txt
@@ -309,7 +309,7 @@ Options
--nologcapture
- Disable logging capture plugin. Logging configurtion will be left
+ Disable logging capture plugin. Logging configuration will be left
intact. [NOSE_NOLOGCAPTURE]
--logging-format=FORMAT
@@ -389,6 +389,11 @@ Options
Produce XML coverage information in file
+--cover-noreport
+
+ Disable coverage report output to stdout/stderr
+ [NOSE_COVER_NOREPORT]
+
--pdb
Drop into debugger on failures or errors
@@ -519,6 +524,11 @@ Options
Path to xml file to store the xunit report in. Default is
nosetests.xml in the working directory [NOSE_XUNIT_FILE]
+--xunit-testsuite-name=PACKAGE
+
+ Name of the testsuite in the xunit xml, generated by plugin.
+ Default test suite name is nosetests.
+
--all-modules
Enable plugin AllModules: Collect tests from all python modules.
diff --git a/nosetests.1 b/nosetests.1
index ced7945..5772845 100644
--- a/nosetests.1
+++ b/nosetests.1
@@ -1,6 +1,6 @@
.\" Man page generated from reStructuredText.
.
-.TH "NOSETESTS" "1" "March 10, 2014" "1.3" "nose"
+.TH "NOSETESTS" "1" "April 04, 2015" "1.3" "nose"
.SH NAME
nosetests \- Nicer testing for Python
.
@@ -326,7 +326,7 @@ Don\(aqt capture stdout (any stdout output will be printed immediately) [NOSE_NO
.INDENT 0.0
.TP
.B \-\-nologcapture
-Disable logging capture plugin. Logging configurtion will be left intact. [NOSE_NOLOGCAPTURE]
+Disable logging capture plugin. Logging configuration will be left intact. [NOSE_NOLOGCAPTURE]
.UNINDENT
.INDENT 0.0
.TP
@@ -557,6 +557,11 @@ Path to xml file to store the xunit report in. Default is nosetests.xml in the w
.UNINDENT
.INDENT 0.0
.TP
+.B \-\-xunit\-testsuite\-name=PACKAGE
+Name of the testsuite in the xunit xml, generated by plugin. Default test suite name is nosetests.
+.UNINDENT
+.INDENT 0.0
+.TP
.B \-\-all\-modules
Enable plugin AllModules: Collect tests from all python modules.
[NOSE_ALL_MODULES]
diff --git a/setup.py b/setup.py
index ef74e4f..4d7e578 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,7 @@
import sys
import os
-VERSION = '1.3.4'
+VERSION = '1.3.5'
py_vers_tag = '-%s.%s' % sys.version_info[:2]
test_dirs = ['functional_tests', 'unit_tests', os.path.join('doc','doc_tests'), 'nose']