summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Szakmeister <john@szakmeister.net>2014-03-28 12:48:26 -0400
committerJohn Szakmeister <john@szakmeister.net>2014-03-28 12:48:26 -0400
commit4edec7237cf26cedae5871189c23a75d791ab975 (patch)
treef8131d6587db4314b822471619785f8b1d0b6abd
parent0ffb07aae4032d010f3b2c9f26834f8b7fb9c578 (diff)
downloadnose-4edec7237cf26cedae5871189c23a75d791ab975.tar.gz
Add Python 3.4 support to tox and drop Python 2.4 and 2.5.
Tox no longer supports the latter two.
-rw-r--r--tox.ini8
1 files changed, 7 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 4d3a3e8..321fd13 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist=py33,py32,py31,py27,py26,py25,py24,jython,docs
+envlist=py34,py33,py32,py31,py27,py26,jython,docs
[testenv]
deps= coverage >=3.3
@@ -55,3 +55,9 @@ commands=
rm -fr {toxinidir}/build
{envpython} setup.py build_tests
{envpython} selftest.py []
+
+[testenv:py34]
+commands=
+ rm -fr {toxinidir}/build
+ {envpython} setup.py build_tests
+ {envpython} selftest.py []