summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--doc/developer/release.rst10
-rw-r--r--requirements/release.txt1
2 files changed, 6 insertions, 5 deletions
diff --git a/doc/developer/release.rst b/doc/developer/release.rst
index 2f290bee..082bcf00 100644
--- a/doc/developer/release.rst
+++ b/doc/developer/release.rst
@@ -42,14 +42,14 @@ Release Process
- Push the new meta-data to github::
- git push --tags upstream main
+ git push --tags origin main
- (where ``upstream`` is the name of the
+ (where ``origin`` is the name of the
``github.com:networkx/networkx`` repository.)
- Review the github release page::
- https://github.com/networkx/networkx/releases
+ https://github.com/networkx/networkx/tags
- Pin badges in ``README.rst``::
@@ -60,7 +60,7 @@ Release Process
git clean -fxd
pip install -r requirements/release.txt
- python setup.py sdist bdist_wheel
+ python -m build --sdist --wheel
twine upload -s dist/*
- Unpin badges in ``README.rst``::
@@ -102,7 +102,7 @@ Release Process
git add networkx/__init__.py doc/_templates/layout.html
git commit -m "Bump release version"
- git push upstream main
+ git push origin main
- Update the web frontpage:
The webpage is kept in a separate repo: networkx/website
diff --git a/requirements/release.txt b/requirements/release.txt
index 24e5b652..4f7d2499 100644
--- a/requirements/release.txt
+++ b/requirements/release.txt
@@ -1,2 +1,3 @@
+build>=0.7
twine>=3.8
wheel>=0.37