summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJarrod Millman <jarrod.millman@gmail.com>2020-12-17 11:02:12 -0800
committerGitHub <noreply@github.com>2020-12-17 11:02:12 -0800
commit5618142c87696c3adfe6490eec65c10098e320c1 (patch)
treef333b0ca2a28f63462399a4bd567837d5b345af6 /setup.py
parent0c3adb519c5d1809a6541fab6868f81ece3cd4f0 (diff)
downloadnetworkx-5618142c87696c3adfe6490eec65c10098e320c1.tar.gz
Drop Py3.6 support per NEP 29 (#4469)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 3c3d86c5..73514221 100644
--- a/setup.py
+++ b/setup.py
@@ -18,9 +18,9 @@ if sys.argv[-1] == "setup.py":
print("To install, run 'python setup.py install'")
print()
-if sys.version_info[:2] < (3, 6):
+if sys.version_info[:2] < (3, 7):
error = (
- "NetworkX 2.5+ requires Python 3.6 or later (%d.%d detected). \n"
+ "NetworkX 2.6+ requires Python 3.7 or later (%d.%d detected). \n"
"For Python 2.7, please install version 2.2 using: \n"
"$ pip install 'networkx==2.2'" % sys.version_info[:2]
)
@@ -162,6 +162,6 @@ if __name__ == "__main__":
package_data=package_data,
install_requires=install_requires,
extras_require=extras_require,
- python_requires=">=3.6",
+ python_requires=">=3.7",
zip_safe=False,
)