summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMridul Seth <seth.mridul@gmail.com>2019-12-08 11:15:16 -0500
committerJarrod Millman <jarrod.millman@gmail.com>2019-12-08 08:15:16 -0800
commit0770b228e0aab5acf8842981947857fdf85205ab (patch)
treef254e8e02999deb0511e4e7b7fef6ed444245984 /setup.py
parent17844fe8b1cc19b174fa8e392d8113548c09f83d (diff)
downloadnetworkx-0770b228e0aab5acf8842981947857fdf85205ab.tar.gz
remove f strings from setup.py for clear error message < py3.6 (#3738)
remove f strings from setup.py for clear error message < py3.6
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 4 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index b93a306d..58afbb25 100644
--- a/setup.py
+++ b/setup.py
@@ -19,11 +19,10 @@ if sys.argv[-1] == "setup.py":
print()
if sys.version_info[:2] < (3, 6):
- python_version = f"{sys.version_info[0]}.{sys.version_info[1]}"
error = (
- f"NetworkX 2.5+ requires Python 3.6 or later ({python_version} detected).\n\n"
- "For Python 2.7, please install version 2.2 using:\n\n"
- "$ pip install 'networkx==2.2'"
+ "NetworkX 2.5+ requires Python 3.6 or later (%d.%d detected). \n"
+ "For Python 2.7, please install version 2.2 using: \n"
+ "$ pip install 'networkx==2.2'" % sys.version_info[:2]
)
sys.stderr.write(error + "\n")
sys.exit(1)
@@ -65,7 +64,7 @@ packages = [
"networkx.utils",
]
-docdirbase = f"share/doc/networkx-{version}"
+docdirbase = "share/doc/networkx-%s" % version
# add basic documentation
data = [(docdirbase, glob("*.txt"))]
# add examples