summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMichael Johnson <johnsom@users.noreply.github.com>2018-07-23 19:46:45 -0700
committerDan Schult <dschult@colgate.edu>2018-07-23 22:46:45 -0400
commit35f3edccef8d48277857ec31070cfe616163583f (patch)
tree4cf13d8a69185699a34f84a24a00d9c0f8f8367c /setup.py
parenta0daf7591e5e7b8648e9aa2a7fc2507cd746c082 (diff)
downloadnetworkx-35f3edccef8d48277857ec31070cfe616163583f.tar.gz
Allow individual extras selection (#3080)
* Allow individual extras selection Currently networkx only has a definition for "all" dependency extras. This patch adds support to specify the individual extras required. Our use case is for pydot where we use nx_pydot but none of the other "extras". * Added missing 'nose' extra
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 13 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 3aff302a..f18d142f 100644
--- a/setup.py
+++ b/setup.py
@@ -118,7 +118,19 @@ package_data = {
install_requires = ['decorator>=4.1.0']
extras_require = {'all': ['numpy', 'scipy', 'pandas', 'matplotlib',
- 'pygraphviz', 'pydot', 'pyyaml', 'gdal', 'lxml','nose']}
+ 'pygraphviz', 'pydot', 'pyyaml', 'gdal', 'lxml',
+ 'nose'],
+ 'gdal': ['gdal'],
+ 'lxml': ['lxml'],
+ 'matplotlib': ['matplotlib'],
+ 'nose': ['nose'],
+ 'numpy': ['numpy'],
+ 'pandas': ['pandas'],
+ 'pydot': ['pydot'],
+ 'pygraphviz': ['pygraphviz'],
+ 'pyyaml': ['pyyaml'],
+ 'scipy': ['scipy']
+ }
if __name__ == "__main__":