summaryrefslogtreecommitdiff
path: root/doc/Makefile
diff options
context:
space:
mode:
authorAric Hagberg <aric.hagberg@gmail.com>2011-05-20 17:44:17 -0600
committerAric Hagberg <aric.hagberg@gmail.com>2011-05-20 17:44:17 -0600
commit4217e25a77b9f3a6ced0573f04b6c33fcdc24640 (patch)
tree0b8c4fe80ecad1e160ec831f30b565c8e2ccc7d7 /doc/Makefile
parentad2f63669d08ed87ff6d8e2cd09519d8b15b1cf2 (diff)
downloadnetworkx-4217e25a77b9f3a6ced0573f04b6c33fcdc24640.tar.gz
Add epub builder for sphinx.
Diffstat (limited to 'doc/Makefile')
-rw-r--r--doc/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/doc/Makefile b/doc/Makefile
index 3aff05a7..5a1808a1 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -11,13 +11,14 @@ PAPEROPT_a4 = -D latex_paper_size=a4
PAPEROPT_letter = -D latex_paper_size=letter
ALLSPHINXOPTS = -d build/doctrees $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) source
-.PHONY: help clean html dirhtml pickle json htmlhelp qthelp latex changes linkcheck doctest
+.PHONY: help clean html dirhtml pickle json htmlhelp qthelp latex changes linkcheck doctest epub
help:
@echo "Please use \`make <target>' where <target> is one of"
@echo " html to make standalone HTML files"
@echo " dirhtml to make HTML files named index.html in directories"
@echo " pickle to make pickle files"
+ @echo " epub to make an epub"
@echo " json to make JSON files"
@echo " htmlhelp to make HTML files and a HTML help project"
@echo " qthelp to make HTML files and a qthelp project"
@@ -89,6 +90,12 @@ qthelp: generate
@echo "To view the help file:"
@echo "# assistant -collectionFile build/qthelp/test.qhc"
+epub:
+ $(SPHINXBUILD) -b epub $(ALLSPHINXOPTS) build/epub
+ @echo
+ @echo "Build finished. The epub file is in $(BUILDDIR)/epub."
+
+
latex: generate
$(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) build/latex
@echo