summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJarrod Millman <jarrod.millman@gmail.com>2022-10-08 18:49:55 -0700
committerJarrod Millman <jarrod.millman@gmail.com>2022-11-01 10:27:10 -0700
commit7566856de005d987a1c61b2a9e0e98ae87ffb0cc (patch)
tree74e367022ad8de1dfa5edc8affd01fc1ce64e774
parentf3c8516325a9fa7cfe38d9f7d8d8a483d7789e5d (diff)
downloadnetworkx-7566856de005d987a1c61b2a9e0e98ae87ffb0cc.tar.gz
Support Python 3.11 (#6023)
-rw-r--r--.github/workflows/test.yml4
-rw-r--r--setup.py1
2 files changed, 3 insertions, 2 deletions
diff --git a/.github/workflows/test.yml b/.github/workflows/test.yml
index 359a329a..3c699afc 100644
--- a/.github/workflows/test.yml
+++ b/.github/workflows/test.yml
@@ -14,7 +14,7 @@ jobs:
strategy:
matrix:
os: [ubuntu, macos, windows]
- python-version: ["pypy-3.8", "3.11-dev"]
+ python-version: ["pypy-3.8"]
steps:
- uses: actions/checkout@v3
- name: Set up Python ${{ matrix.python-version }}
@@ -38,7 +38,7 @@ jobs:
strategy:
matrix:
os: [ubuntu, macos, windows]
- python-version: ["3.8", "3.9", "3.10"]
+ python-version: ["3.8", "3.9", "3.10", "3.11-dev"]
steps:
- uses: actions/checkout@v3
- name: Set up Python ${{ matrix.python-version }}
diff --git a/setup.py b/setup.py
index b6464d2f..e201ec34 100644
--- a/setup.py
+++ b/setup.py
@@ -48,6 +48,7 @@ classifiers = [
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
"Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
"Programming Language :: Python :: 3 :: Only",
"Topic :: Software Development :: Libraries :: Python Modules",
"Topic :: Scientific/Engineering :: Bio-Informatics",