summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorysitu <ysitu@users.noreply.github.com>2014-06-03 14:13:35 -0400
committerysitu <ysitu@users.noreply.github.com>2014-06-03 14:13:35 -0400
commit86c3606f8abb883107d2afcf66ff670fcf94a213 (patch)
treea6d240ade9ab856ffbe4935829f0c36c9e405a28
parent910a02edffa7894007784582e38ca07c87817f64 (diff)
downloadnetworkx-86c3606f8abb883107d2afcf66ff670fcf94a213.tar.gz
Force use of setuptools
-rw-r--r--setup.py8
1 files changed, 1 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 3f70ea6e..91071eff 100644
--- a/setup.py
+++ b/setup.py
@@ -13,10 +13,7 @@ import sys
if os.path.exists('MANIFEST'):
os.remove('MANIFEST')
-try:
- from setuptools import setup
-except ImportError:
- from distutils.core import setup
+from setuptools import setup
if sys.argv[-1] == 'setup.py':
print("To install, run 'python setup.py install'")
@@ -118,8 +115,6 @@ package_data = {
'networkx.utils': ['tests/*.py']
}
-install_requires = ['setuptools']
-
if __name__ == "__main__":
setup(
@@ -140,7 +135,6 @@ if __name__ == "__main__":
packages = packages,
data_files = data,
package_data = package_data,
- install_requires = install_requires,
test_suite = 'nose.collector',
tests_require = ['nose>=0.10.1'],
zip_safe = False