summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoss Barnowski <rossbar@berkeley.edu>2022-09-11 05:56:41 -0700
committerGitHub <noreply@github.com>2022-09-11 08:56:41 -0400
commit034274e08b3b78022e47d03cc5e69e28be23f713 (patch)
tree0ea4b1289942d664eedcb5d6f74632960370ff91
parent287b2484fd4ac83bd36d5e7be0db4dbf373aefad (diff)
downloadnetworkx-034274e08b3b78022e47d03cc5e69e28be23f713.tar.gz
Add vf2pp_helpers subpackage to wheel (#5975)
* Add vf2pp_helpers to package. * Add __init__.py to vf2pp_helpers
-rw-r--r--networkx/algorithms/isomorphism/vf2pp_helpers/__init__.py0
-rw-r--r--setup.py8
2 files changed, 6 insertions, 2 deletions
diff --git a/networkx/algorithms/isomorphism/vf2pp_helpers/__init__.py b/networkx/algorithms/isomorphism/vf2pp_helpers/__init__.py
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/networkx/algorithms/isomorphism/vf2pp_helpers/__init__.py
diff --git a/setup.py b/setup.py
index cd7f4a4a..02813bdf 100644
--- a/setup.py
+++ b/setup.py
@@ -121,7 +121,7 @@ dd = os.path.join(docdirbase, "examples", "javascript/force")
pp = os.path.join("examples", "javascript/force")
data.append((dd, glob(os.path.join(pp, "*"))))
-# add the tests
+# add the tests and helper subpackage(s)
package_data = {
"networkx": ["tests/*.py"],
"networkx.algorithms": ["tests/*.py"],
@@ -134,7 +134,11 @@ package_data = {
"networkx.algorithms.coloring": ["tests/*.py"],
"networkx.algorithms.minors": ["tests/*.py"],
"networkx.algorithms.flow": ["tests/*.py", "tests/*.bz2"],
- "networkx.algorithms.isomorphism": ["tests/*.py", "tests/*.*99"],
+ "networkx.algorithms.isomorphism": [
+ "tests/*.py",
+ "tests/*.*99",
+ "vf2pp_helpers/*.py",
+ ],
"networkx.algorithms.link_analysis": ["tests/*.py"],
"networkx.algorithms.approximation": ["tests/*.py"],
"networkx.algorithms.operators": ["tests/*.py"],