summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Houghton <alastair@coriolis-systems.com>2012-01-31 11:46:59 +0000
committerAlastair Houghton <alastair@coriolis-systems.com>2012-01-31 11:46:59 +0000
commiteb2e76937c6dc5b18e55880bc6b95cbac1cb416e (patch)
tree7237cb92ded3244e957433ef8ad2908a3610e8b4
parent9714364f36a9a324253938fbf28e4a7d02d88d7f (diff)
downloadnetifaces-eb2e76937c6dc5b18e55880bc6b95cbac1cb416e.tar.gz
Fixed a problem with setup.py when some things are cached.
-rw-r--r--setup.py10
1 files changed, 10 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 023ddfd..eefe10d 100644
--- a/setup.py
+++ b/setup.py
@@ -201,6 +201,11 @@ class my_build_ext(build_ext):
else:
cached = ''
+ if not os.path.exists(self.build_temp):
+ os.makedirs(self.build_temp)
+ outname = os.path.join(self.build_temp, 'conftest3.out')
+ self.ctout = os.open(outname, os.O_RDWR | os.O_CREAT | os.O_TRUNC)
+
result = []
ioctls = ('SIOCGIFCONF',
'SIOCGSIZIFCONF',
@@ -337,6 +342,11 @@ class my_build_ext(build_ext):
else:
cached = ''
+ if not os.path.exists(self.build_temp):
+ os.makedirs(self.build_temp)
+ outname = os.path.join(self.build_temp, 'conftest4.out')
+ self.ctout = os.open(outname, os.O_RDWR | os.O_CREAT | os.O_TRUNC)
+
sockaddrs = ('at', 'ax25', 'dl', 'eon', 'in', 'in6',
'inarp', 'ipx', 'iso', 'ns', 'un', 'x25',
'rose', 'ash', 'ec', 'll', 'atmpvc', 'atmsvc',