summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Houghton <alastair@coriolis-systems.com>2014-04-28 18:17:16 +0100
committerAlastair Houghton <alastair@coriolis-systems.com>2014-04-28 18:17:16 +0100
commit5ce3575775909c02aea6d996b89c862b7e2ca76f (patch)
tree4bf7c88d7203fd51883f8257d3ee4a61e3179f2d
parent3355dea76276ea73732b2c31c2b5a3ec22b540ed (diff)
downloadnetifaces-5ce3575775909c02aea6d996b89c862b7e2ca76f.tar.gz
Updated version number. Made the README explicitly reStructuredText
-rw-r--r--README.rst (renamed from README)16
-rw-r--r--setup.py25
2 files changed, 23 insertions, 18 deletions
diff --git a/README b/README.rst
index 2b53be6..8fd7ced 100644
--- a/README
+++ b/README.rst
@@ -1,5 +1,5 @@
-netifaces 0.9
-=============
+netifaces 0.10.0
+================
.. image:: https://drone.io/bitbucket.org/al45tair/netifaces/status.png
:target: https://drone.io/bitbucket.org/al45tair/netifaces/latest
@@ -24,8 +24,8 @@ This package attempts to solve that problem.
First you need to install it, which you can do by typing::
- tar xvzf netifaces-0.9.tar.gz
- cd netifaces-0.9
+ tar xvzf netifaces-0.10.0.tar.gz
+ cd netifaces-0.10.0
python setup.py install
Once that's done, you'll need to start Python and do something like the
@@ -154,4 +154,10 @@ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-SOFTWARE. \ No newline at end of file
+SOFTWARE.
+
+5. Why the jump to 0.10.0?
+--------------------------
+
+Because someone released a fork of netifaces with the version 0.9.0.
+Hopefully skipping the version number should remove any confusion.
diff --git a/setup.py b/setup.py
index 1cdeb7e..3cf99bf 100644
--- a/setup.py
+++ b/setup.py
@@ -16,7 +16,7 @@ if sys.version_info[0] == 2:
else:
output = getattr(__builtins__, 'print')
-__version__ = "0.9"
+__version__ = "0.10.0"
# Disable hard links, otherwise building distributions fails on OS X
try:
@@ -403,22 +403,15 @@ class my_build_ext(build_ext):
if not getattr(sys, 'getwindowsversion', None):
setuptools.command.build_ext.build_ext = my_build_ext
+readme_path = os.path.join(os.path.abspath(os.path.dirname(__file__)),
+ 'README.rst')
+long_desc = open(readme_path, 'r').read()
+
setup (name='netifaces',
version=__version__,
description="Portable network interface information.",
license="MIT License",
- long_description="""\
-netifaces provides a (hopefully portable-ish) way for Python programmers to
-get access to a list of the network interfaces on the local machine, and to
-obtain the addresses of those network interfaces.
-
-The package has been tested on Mac OS X, Windows XP, Windows Vista, Linux
-and Solaris.
-
-It should work on other UNIX-like systems provided they implement
-either getifaddrs() or support the SIOCGIFxxx socket options, although the
-data provided by the socket options is normally less complete.
-""",
+ long_description=long_desc,
author='Alastair Houghton',
author_email='alastair@alastairs-place.net',
url='http://alastairs-place.net/netifaces',
@@ -427,5 +420,11 @@ data provided by the socket options is normally less complete.
'Intended Audience :: Developers',
'License :: OSI Approved :: MIT License',
'Topic :: System :: Networking',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.5',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
],
ext_modules=[iface_mod])