summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Houghton <alastair@coriolis-systems.com>2014-05-03 20:30:15 +0100
committerAlastair Houghton <alastair@coriolis-systems.com>2014-05-03 20:30:15 +0100
commit197c465b0038ca85b6f7abb7849848c51408dbdd (patch)
tree3dec38f03921518599484050080058f7575d6ed8
parent5d960b314d795d498ccd3cba0dbdf81f26a5fb77 (diff)
downloadnetifaces-197c465b0038ca85b6f7abb7849848c51408dbdd.tar.gz
Added a workaround for broken netlink headers on some Linux distros.release_0_10_2
-rw-r--r--CHANGELOG6
-rw-r--r--README.rst6
-rw-r--r--setup.py4
3 files changed, 11 insertions, 5 deletions
diff --git a/CHANGELOG b/CHANGELOG
index b448280..b322b50 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,9 @@
+2014-05-03 Version 0.10.2
+
+ * Added a workaround for broken netlink headers on certain Linux
+ distributions (the problem being that the netlink headers fail to
+ include <bits/sockaddr.h>, which causes a build failure).
+
2014-05-02 Version 0.10.1
* Fixed a problem with the gateways() function that caused it a
diff --git a/README.rst b/README.rst
index ebfd9ca..3246c55 100644
--- a/README.rst
+++ b/README.rst
@@ -1,4 +1,4 @@
-netifaces 0.10.1
+netifaces 0.10.2
================
.. image:: https://drone.io/bitbucket.org/al45tair/netifaces/status.png
@@ -24,8 +24,8 @@ This package attempts to solve that problem.
First you need to install it, which you can do by typing::
- tar xvzf netifaces-0.10.0.tar.gz
- cd netifaces-0.10.0
+ tar xvzf netifaces-0.10.2.tar.gz
+ cd netifaces-0.10.2
python setup.py install
Once that's done, you'll need to start Python and do something like the
diff --git a/setup.py b/setup.py
index 96e7afc..db46b11 100644
--- a/setup.py
+++ b/setup.py
@@ -16,7 +16,7 @@ if sys.version_info[0] == 2:
else:
output = getattr(__builtins__, 'print')
-__version__ = "0.10.1"
+__version__ = "0.10.2"
# Disable hard links, otherwise building distributions fails on OS X
try:
@@ -466,9 +466,9 @@ class my_build_ext(build_ext):
testrig = """
#include <asm/types.h>
+ #include <sys/socket.h>
#include <linux/netlink.h>
#include <linux/rtnetlink.h>
- #include <sys/socket.h>
int main (void) {
int s = socket (PF_NETLINK, SOCK_RAW, NETLINK_ROUTE);