summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Morton <seth.m.morton@gmail.com>2020-01-08 22:45:21 -0800
committerSeth Morton <seth.m.morton@gmail.com>2020-01-08 22:45:21 -0800
commit4188fb8166dfd413ad1d22ee3dcdb904e600b5a8 (patch)
tree15cc11afb809c49b2cc2e6a0b0f227d4a293ce26
parent253fd5e72983913b4949376aea6d2caa7dadb956 (diff)
downloadnatsort-4188fb8166dfd413ad1d22ee3dcdb904e600b5a8.tar.gz
Bump version: 6.2.0 → 7.0.07.0.0
-rw-r--r--CHANGELOG.md4
-rw-r--r--docs/conf.py2
-rw-r--r--natsort/__init__.py2
-rw-r--r--setup.cfg2
-rw-r--r--setup.py2
5 files changed, 8 insertions, 4 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 442ecba..2db3d5b 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,9 @@
Unreleased
---
+[7.0.0] - 2020-01-08
+---
+
### Added
- Ability to deploy directly from TravisCI ([@hugovk](https://github.com/hugovk), issue #106)
- Release checklist in `RELEASING.md` ([@hugovk](https://github.com/hugovk), issue #106)
@@ -520,6 +523,7 @@ a pipeline by which to filter
- Sorting algorithm to support floats (including exponentials) and basic version number support
<!---Comparison links-->
+[7.0.0]: https://github.com/SethMMorton/natsort/compare/6.2.0...7.0.0
[6.2.0]: https://github.com/SethMMorton/natsort/compare/6.1.0...6.2.0
[6.1.0]: https://github.com/SethMMorton/natsort/compare/6.0.0...6.1.0
[6.0.0]: https://github.com/SethMMorton/natsort/compare/5.5.0...6.0.0
diff --git a/docs/conf.py b/docs/conf.py
index bd6c2e0..4dca26d 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -58,7 +58,7 @@ copyright = '2014, Seth M. Morton'
# built documents.
#
# The full version, including alpha/beta/rc tags.
-release = '6.2.0'
+release = '7.0.0'
# The short X.Y version.
version = '.'.join(release.split('.')[0:2])
diff --git a/natsort/__init__.py b/natsort/__init__.py
index 4a838fc..26cd0a8 100644
--- a/natsort/__init__.py
+++ b/natsort/__init__.py
@@ -18,7 +18,7 @@ from natsort.natsort import (
)
from natsort.utils import chain_functions
-__version__ = "6.2.0"
+__version__ = "7.0.0"
__all__ = [
"natsort_key",
diff --git a/setup.cfg b/setup.cfg
index 0e0f872..07fbfd7 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,5 @@
[bumpversion]
-current_version = 6.2.0
+current_version = 7.0.0
commit = True
tag = True
tag_name = {new_version}
diff --git a/setup.py b/setup.py
index e958aaf..c5ca32e 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@
from setuptools import find_packages, setup
setup(
name='natsort',
- version='6.2.0',
+ version='7.0.0',
packages=find_packages(),
entry_points={'console_scripts': ['natsort = natsort.__main__:main']},
python_requires=">=3.4",