summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth M Morton <seth.m.morton@gmail.com>2015-06-25 08:28:30 -0700
committerSeth M Morton <seth.m.morton@gmail.com>2015-06-25 08:29:02 -0700
commit03cc17b9f5c9e6ff30f5c12ed276e672c91b0371 (patch)
tree6b67e6b8111e3e9a43fa4a9421399a3d8e68daa7
parentbc7744fc77f876887f8c63829b221857ce9b89ed (diff)
parent3ae90776d14accd0d21be677ec0adc6c5eb7ce7b (diff)
downloadnatsort-03cc17b9f5c9e6ff30f5c12ed276e672c91b0371.tar.gz
natsort version 4.0.3 releasev4.0.34.0.3
- Fixed missing compat folder on install.
-rw-r--r--MANIFEST.in13
-rw-r--r--README.rst24
-rw-r--r--docs/source/changelog.rst5
-rw-r--r--natsort/_version.py2
-rw-r--r--setup.py2
5 files changed, 23 insertions, 23 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index b4422d9..96e4e99 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -8,7 +8,13 @@ include natsort/locale_help.py
include natsort/utils.py
include natsort/ns_enum.py
include natsort/unicode_numbers.py
-graft natsort/compat
+include natsort/compat/__init__.py
+include natsort/compat/py23.py
+include natsort/compat/fake_fastnumbers.py
+include natsort/compat/fastnumbers.py
+include natsort/compat/locale.py
+include natsort/compat/pathlib.py
+include natsort/compat/pathlib.py
include test_natsort/profile_natsorted.py
include test_natsort/stress_natsort.py
include test_natsort/slow_splitters.py
@@ -18,7 +24,10 @@ include test_natsort/test_fake_fastnumbers.py
include test_natsort/test_main.py
include test_natsort/test_utils.py
include test_natsort/test_unicode_numbers.py
-graft test_natsort/compat
+include test_natsort/compat/__init__.py
+include test_natsort/compat/hypothesis.py
+include test_natsort/compat/locale.py
+include test_natsort/compat/mock.py
include setup.py
include setup.cfg
prune natsort/__pycache__
diff --git a/README.rst b/README.rst
index 2726bc6..3627e40 100644
--- a/README.rst
+++ b/README.rst
@@ -225,6 +225,11 @@ History
These are the last three entries of the changelog. See the package documentation
for the complete `changelog <http://pythonhosted.org//natsort/changelog.html>`_.
+06-25-2015 v. 4.0.3
+'''''''''''''''''''
+
+ - Fixed bad install on last release (sorry guys!).
+
06-24-2015 v. 4.0.2
'''''''''''''''''''
@@ -237,22 +242,3 @@ for the complete `changelog <http://pythonhosted.org//natsort/changelog.html>`_.
- Added support for sorting NaN by internally converting to -Infinity
or +Infinity
-
-05-17-2015 v. 4.0.0
-'''''''''''''''''''
-
- - Made default behavior of 'natsort' search for unsigned ints,
- rather than signed floats. This is a backwards-incompatible
- change but in 99% of use cases it should not require any
- end-user changes.
- - Improved handling of locale-aware sorting on systems where the
- underlying locale library is broken.
- - Greatly improved all unit tests by adding the hypothesis library.
-
-04-06-2015 v. 3.5.6
-'''''''''''''''''''
-
- - Added 'UNGROUPLETTERS' algorithm to get the case-grouping behavior of
- an ordinal sort when using 'LOCALE'.
- - Added convenience functions 'decoder', 'as_ascii', and 'as_utf8' for
- dealing with bytes types.
diff --git a/docs/source/changelog.rst b/docs/source/changelog.rst
index 42942de..5a7d897 100644
--- a/docs/source/changelog.rst
+++ b/docs/source/changelog.rst
@@ -3,6 +3,11 @@
Changelog
---------
+06-25-2015 v. 4.0.3
+'''''''''''''''''''
+
+ - Fixed bad install on last release (sorry guys!).
+
06-24-2015 v. 4.0.2
'''''''''''''''''''
diff --git a/natsort/_version.py b/natsort/_version.py
index 035ff28..8c229c5 100644
--- a/natsort/_version.py
+++ b/natsort/_version.py
@@ -6,4 +6,4 @@ from __future__ import (
absolute_import
)
-__version__ = '4.0.2'
+__version__ = '4.0.3'
diff --git a/setup.py b/setup.py
index b9ef737..3a4979f 100644
--- a/setup.py
+++ b/setup.py
@@ -80,7 +80,7 @@ setup(
url='https://github.com/SethMMorton/natsort',
license='MIT',
install_requires=REQUIRES,
- packages=['natsort'],
+ packages=['natsort', 'natsort.compat'],
entry_points={'console_scripts': ['natsort = natsort.__main__:main']},
tests_require=TESTS_REQUIRE,
cmdclass={'test': PyTest},