summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth M Morton <seth.m.morton@gmail.com>2018-05-16 20:55:27 -0700
committerSeth M Morton <seth.m.morton@gmail.com>2018-05-16 21:00:17 -0700
commita8c31574c496f2480d642026be5b5af6431ea59a (patch)
tree3ce90f1d89ff2fc52e9b80938dd4f76fbfd61733
parent1e83affd5e89818b3fb50bccd38dd677b7384aa8 (diff)
downloadnatsort-a8c31574c496f2480d642026be5b5af6431ea59a.tar.gz
Move some data from setup.cfg back to setup.py.
Old versions of setuptools cannot read from setup.cfg, so they do not properly install natsort because data needed at installation time is not present.
-rw-r--r--setup.cfg16
-rw-r--r--setup.py8
2 files changed, 8 insertions, 16 deletions
diff --git a/setup.cfg b/setup.cfg
index 448af80..af025fe 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,6 +1,4 @@
[metadata]
-name = natsort
-version = 5.3.1
author = Seth M. Morton
author_email = drtuba78@gmail.com
url = https://github.com/SethMMorton/natsort
@@ -29,20 +27,6 @@ classifiers =
Topic :: Utilities
Topic :: Text Processing
-[options]
-install_requires =
- argparse; python_version < '2.7'
-
-[options.entry_points]
-console_scripts =
- natsort = natsort.__main__:main
-
-[options.extras_require]
-fast =
- fastnumbers >= 2.0.0; python_version > '2.6'
-icu =
- PyICU >= 1.0.0
-
[bdist_wheel]
universal = 1
diff --git a/setup.py b/setup.py
index 81bd74a..70671ea 100644
--- a/setup.py
+++ b/setup.py
@@ -2,6 +2,14 @@
from setuptools import setup, find_packages
setup(
+ name='natsort',
+ version='5.3.1',
packages=find_packages('src'),
package_dir={'': 'src'},
+ install_requires=["argparse; python_version < '2.7'"],
+ entry_points={'console_scripts': ['natsort = natsort.__main__:main']},
+ extras_require={
+ 'fast': ["fastnumbers >= 2.0.0; python_version > '2.6'"],
+ 'icu': ["PyICU >= 1.0.0"]
+ }
)