summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorINADA Naoki <songofacandy@gmail.com>2018-01-07 01:59:14 +0900
committerINADA Naoki <songofacandy@gmail.com>2018-01-07 01:59:14 +0900
commit9f4c12f29ce7a6d62423311ab12a031dc79c458a (patch)
tree3f8d3743466bfeca4eea37e7bfc489d8b809f11a
parentd720c42468c2e9cad2c04e28c23917187fa64412 (diff)
downloadmsgpack-python-9f4c12f29ce7a6d62423311ab12a031dc79c458a.tar.gz
Add transition package
-rw-r--r--dummy/README2
-rw-r--r--dummy/setup.py31
2 files changed, 33 insertions, 0 deletions
diff --git a/dummy/README b/dummy/README
new file mode 100644
index 0000000..bf1eeb6
--- /dev/null
+++ b/dummy/README
@@ -0,0 +1,2 @@
+This is dummy transition package for msgpak.
+Install msgpack instead of msgpack-python.
diff --git a/dummy/setup.py b/dummy/setup.py
new file mode 100644
index 0000000..0f1e6e7
--- /dev/null
+++ b/dummy/setup.py
@@ -0,0 +1,31 @@
+from setuptools import setup, Extension
+
+long_desc = """\
+msgpack-python is renamed to just msgpack.
+
+Install msgpack by ``pip install msgpack``.
+"""
+
+
+setup(name='msgpack-python',
+ author='INADA Naoki',
+ author_email='songofacandy@gmail.com',
+ version="0.5.0",
+ description="Transition package for msgpack",
+ long_description=long_desc,
+ install_requires=["msgpack>=0.5"],
+ url='http://msgpack.org/',
+ license='Apache 2.0',
+ classifiers=[
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: Implementation :: PyPy',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: Apache Software License',
+ ],
+)