summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorINADA Naoki <songofacandy@gmail.com>2016-07-21 19:33:49 +0900
committerINADA Naoki <songofacandy@gmail.com>2016-07-21 19:33:49 +0900
commit83e7b0aeac475341d5508e1f0f135068bc41900f (patch)
tree1d56857f63e5fcafcad4eb2acb58dd964427eb31
parent0ef5f4d691ca084c74bd2d294157d022cf9b1cfa (diff)
parentb911b3c652e190e6942a610fb3389aaaf2ccf3cc (diff)
downloadmsgpack-python-83e7b0aeac475341d5508e1f0f135068bc41900f.tar.gz
Merge branch 'release-0.4'
-rw-r--r--appveyor.yml5
-rw-r--r--msgpack/unpack.h4
-rwxr-xr-xsetup.py2
3 files changed, 4 insertions, 7 deletions
diff --git a/appveyor.yml b/appveyor.yml
index 02b4461..9e766c5 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -13,10 +13,7 @@ environment:
- PYTHON: "C:\\Python27-x64"
- PYTHON: "C:\\Python34-x64"
DISTUTILS_USE_SDK: "1"
-
- # Python35-x64 test fails with MemoryError
- # TODO: investigate it
- #- PYTHON: "C:\\Python35-x64"
+ - PYTHON: "C:\\Python35-x64"
install:
# We need wheel installed to build wheels
diff --git a/msgpack/unpack.h b/msgpack/unpack.h
index 92f4f11..da2cfb6 100644
--- a/msgpack/unpack.h
+++ b/msgpack/unpack.h
@@ -265,9 +265,9 @@ static inline int unpack_callback_ext(unpack_user* u, const char* base, const ch
}
// length also includes the typecode, so the actual data is length-1
#if PY_MAJOR_VERSION == 2
- py = PyObject_CallFunction(u->ext_hook, "(is#)", typecode, pos, length-1);
+ py = PyObject_CallFunction(u->ext_hook, "(is#)", (int)typecode, pos, (Py_ssize_t)length-1);
#else
- py = PyObject_CallFunction(u->ext_hook, "(iy#)", typecode, pos, length-1);
+ py = PyObject_CallFunction(u->ext_hook, "(iy#)", (int)typecode, pos, (Py_ssize_t)length-1);
#endif
if (!py)
return -1;
diff --git a/setup.py b/setup.py
index d62c8f2..5f0f08c 100755
--- a/setup.py
+++ b/setup.py
@@ -21,7 +21,7 @@ except ImportError:
def cythonize(src):
sys.stderr.write("cythonize: %r\n" % (src,))
- cython_compiler.compile([src], cplus=True, emit_linenums=True)
+ cython_compiler.compile([src], cplus=True)
def ensure_source(src):
pyx = os.path.splitext(src)[0] + '.pyx'