summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo <hugovk@users.noreply.github.com>2017-11-02 11:06:15 +0200
committerINADA Naoki <methane@users.noreply.github.com>2017-11-02 18:06:15 +0900
commit3a098851bea500ef1ffde856a60d80ddab230dee (patch)
tree33d1515ac249dee1edbeaab1f97c37f7bd5780c9
parent1985eb7618296e6a93c8abc4a697c7b00fda72f8 (diff)
downloadmsgpack-python-3a098851bea500ef1ffde856a60d80ddab230dee.tar.gz
Remove code and tests for unsupported Python 3.3 and 3.4 (#249)
-rw-r--r--.travis.yml2
-rw-r--r--appveyor.yml13
-rw-r--r--build.cmd21
-rwxr-xr-xdocker/runtests.sh2
-rw-r--r--tox.ini2
5 files changed, 6 insertions, 34 deletions
diff --git a/.travis.yml b/.travis.yml
index 54e0c62..7aac664 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -4,8 +4,6 @@ cache: pip
python:
- "2.7"
- - "3.3"
- - "3.4"
- "3.5"
- "3.6"
- "3.7-dev"
diff --git a/appveyor.yml b/appveyor.yml
index e63423d..d581839 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -23,24 +23,19 @@ build: off
test_script:
# Put your test command here.
- # If you don't need to build C extensions on 64-bit Python 3.3 or 3.4,
- # you can remove "build.cmd" from the front of the command, as it's
- # only needed to support those cases.
# Note that you must use the environment variable %PYTHON% to refer to
# the interpreter you're using - Appveyor does not do anything special
# to put the Python version you want to use on PATH.
- - "build.cmd %PYTHON%\\python.exe setup.py build_ext -i"
- - "build.cmd %PYTHON%\\python.exe setup.py install"
+ - "%PYTHON%\\python.exe setup.py build_ext -i"
+ - "%PYTHON%\\python.exe setup.py install"
- "%PYTHON%\\python.exe -c \"import sys; print(hex(sys.maxsize))\""
- "%PYTHON%\\python.exe -c \"from msgpack import _packer, _unpacker\""
- "%PYTHON%\\Scripts\\py.test test"
- - "build.cmd %PYTHON%\\python.exe setup.py bdist_wheel"
+ - "%PYTHON%\\python.exe setup.py bdist_wheel"
after_test:
# This step builds your wheels.
- # Again, you only need build.cmd if you're building C extensions for
- # 64-bit Python 3.3/3.4. And you need to use %PYTHON% to get the correct
- # interpreter
+ # Again, you need to use %PYTHON% to get the correct interpreter
artifacts:
# bdist_wheel puts your built wheel in the dist directory
diff --git a/build.cmd b/build.cmd
deleted file mode 100644
index 243dc9a..0000000
--- a/build.cmd
+++ /dev/null
@@ -1,21 +0,0 @@
-@echo off
-:: To build extensions for 64 bit Python 3, we need to configure environment
-:: variables to use the MSVC 2010 C++ compilers from GRMSDKX_EN_DVD.iso of:
-:: MS Windows SDK for Windows 7 and .NET Framework 4
-::
-:: More details at:
-:: https://github.com/cython/cython/wiki/64BitCythonExtensionsOnWindows
-
-IF "%DISTUTILS_USE_SDK%"=="1" (
- ECHO Configuring environment to build with MSVC on a 64bit architecture
- ECHO Using Windows SDK 7.1
- "C:\Program Files\Microsoft SDKs\Windows\v7.1\Setup\WindowsSdkVer.exe" -q -version:v7.1
- CALL "C:\Program Files\Microsoft SDKs\Windows\v7.1\Bin\SetEnv.cmd" /x64 /release
- SET MSSdk=1
- REM Need the following to allow tox to see the SDK compiler
- SET TOX_TESTENV_PASSENV=DISTUTILS_USE_SDK MSSdk INCLUDE LIB
-) ELSE (
- ECHO Using default MSVC build environment
-)
-
-CALL %*
diff --git a/docker/runtests.sh b/docker/runtests.sh
index 0eea715..11ef9f4 100755
--- a/docker/runtests.sh
+++ b/docker/runtests.sh
@@ -1,7 +1,7 @@
#!/bin/bash
set -e -x
-for V in cp36-cp36m cp35-cp35m cp34-cp34m cp27-cp27m cp27-cp27mu; do
+for V in cp36-cp36m cp35-cp35m cp27-cp27m cp27-cp27mu; do
PYBIN=/opt/python/$V/bin
$PYBIN/python setup.py install
rm -rf build/ # Avoid lib build by narrow Python is used by wide python
diff --git a/tox.ini b/tox.ini
index b2ac336..68a2f53 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = {py27,py33,py34,py35,py36}-{c,pure},{pypy,pypy3}-pure,py27-x86,py34-x86
+envlist = {py27,py35,py36}-{c,pure},{pypy,pypy3}-pure,py27-x86,py34-x86
[variants:pure]
setenv=