summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorINADA Naoki <inada-n@klab.com>2013-10-21 01:47:54 +0900
committerINADA Naoki <inada-n@klab.com>2013-10-21 01:47:54 +0900
commitf31a4403a1715ea5b48a12e1aa58df0e74b7e85f (patch)
treeec7a77f177acba976bdeacc7573a8fe13223cabb
parent1d0096b998abca1276b88ae6960316f8cff273b9 (diff)
downloadmsgpack-python-f31a4403a1715ea5b48a12e1aa58df0e74b7e85f.tar.gz
Document update.
-rw-r--r--Makefile3
-rw-r--r--docs/api.rst2
-rw-r--r--docs/conf.py2
-rw-r--r--msgpack/__init__.py1
4 files changed, 7 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 71be6af..2e53d08 100644
--- a/Makefile
+++ b/Makefile
@@ -9,6 +9,9 @@ doc-serve: all
doc:
cd docs && make zip
+upload-doc:
+ python setup.py upload_docs --upload-dir docs/_build/html
+
cython:
cython --cplus msgpack/*.pyx
diff --git a/docs/api.rst b/docs/api.rst
index 50a84c4..841c134 100644
--- a/docs/api.rst
+++ b/docs/api.rst
@@ -25,6 +25,8 @@ API reference
.. autoclass:: Unpacker
:members:
+.. autoclass:: ExtType
+
exceptions
-----------
diff --git a/docs/conf.py b/docs/conf.py
index fba09b7..0f19fcc 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -49,7 +49,7 @@ copyright = u'2013, INADA Naoki'
#
# The short X.Y version.
# The full version, including alpha/beta/rc tags.
-version = release = '0.3'
+version = release = '0.4'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/msgpack/__init__.py b/msgpack/__init__.py
index a958025..6c5ae53 100644
--- a/msgpack/__init__.py
+++ b/msgpack/__init__.py
@@ -6,6 +6,7 @@ from collections import namedtuple
class ExtType(namedtuple('ExtType', 'code data')):
+ """ExtType represents ext type in msgpack."""
def __new__(cls, code, data):
if not isinstance(code, int):
raise TypeError("code must be int")