summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorINADA Naoki <songofacandy@gmail.com>2012-04-21 14:25:07 +0900
committerINADA Naoki <songofacandy@gmail.com>2012-04-21 14:25:07 +0900
commit7a4af28fa1599f49cc0a27c66beecd5e4474dcbe (patch)
tree25947e3dfd171011dcdaef37701be8a6f2e0378f
parent91a1abb737ecdcc88392355a6d157be5d9040477 (diff)
downloadmsgpack-python-7a4af28fa1599f49cc0a27c66beecd5e4474dcbe.tar.gz
release 0.1.130.1.13
-rw-r--r--ChangeLog.rst21
-rwxr-xr-xsetup.py2
2 files changed, 22 insertions, 1 deletions
diff --git a/ChangeLog.rst b/ChangeLog.rst
index 89a97d7..e0a4fd1 100644
--- a/ChangeLog.rst
+++ b/ChangeLog.rst
@@ -1,3 +1,24 @@
+0.1.13
+=======
+:release date: 2012-04-21
+
+New
+----
+* Don't accept subtype of list and tuple as msgpack list. (Steeve Morin)
+ It allows customize how it serialized with ``default`` argument.
+
+Bugs fixed
+-----------
+* Fix wrong error message. (David Wolever)
+* Fix memory leak while unpacking when ``object_hook`` or ``list_hook`` is used.
+ (Steeve Morin)
+
+Other changes
+-------------
+* setup.py works on Python 2.5 (Steffen Siering)
+* Optimization for serializing dict.
+
+
0.1.12
=======
:release date: 2011-12-27
diff --git a/setup.py b/setup.py
index f34e341..b4b1771 100755
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
#!/usr/bin/env python
# coding: utf-8
-version = (0, 1, 12)
+version = (0, 1, 13)
import os
import sys