summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 47cca43..cc54251 100644
--- a/setup.py
+++ b/setup.py
@@ -137,6 +137,11 @@ class MyBuildPy(build_py):
dest = join(basedir, directory)
shutil.rmtree(dest, ignore_errors=True)
shutil.copytree(directory, dest)
+ if sys.version_info >= (3, 0):
+ # process manually python file in include_dirs (test data)
+ from subprocess import check_call
+ print('running 2to3 on', dest) # brackets are NOT optional here for py3k compat
+ check_call(['2to3', '-wn', dest])
def install(**kwargs):