summaryrefslogtreecommitdiff
path: root/debian.lenny
diff options
context:
space:
mode:
authorJulien Jehannet <julien.jehannet@logilab.fr>2009-09-15 15:01:53 +0200
committerJulien Jehannet <julien.jehannet@logilab.fr>2009-09-15 15:01:53 +0200
commit028ddb178ec0276bd03b4b9694c3faf1d715a9dd (patch)
treead716de21d565adb568366c0f5ad472aae5f3395 /debian.lenny
parent31f761f57d265e133233b7e46d5cee6df2c71b13 (diff)
downloadlogilab-common-028ddb178ec0276bd03b4b9694c3faf1d715a9dd.tar.gz
[C] debian: refactoring and merge specific cases into unique debian directory
Diffstat (limited to 'debian.lenny')
-rwxr-xr-xdebian.lenny/rules73
1 files changed, 0 insertions, 73 deletions
diff --git a/debian.lenny/rules b/debian.lenny/rules
deleted file mode 100755
index f468406..0000000
--- a/debian.lenny/rules
+++ /dev/null
@@ -1,73 +0,0 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-#
-# adapted by Logilab for automatic generation by debianize
-# (part of the devtools project, http://www.logilab.org/projects/devtools)
-#
-# Copyright (c) 2003-2008 LOGILAB S.A. (Paris, FRANCE).
-# http://www.logilab.fr/ -- mailto:contact@logilab.fr
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-build: build-stamp
-build-stamp:
- dh_testdir
-
- # python module build
- NO_SETUPTOOLS=1 python setup.py -q build
-
- # build doc
- $(MAKE) -C doc
-
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
-
- # clean doc
- $(MAKE) -C doc clean
-
- NO_SETUPTOOLS=1 python setup.py clean
-
- [ ! -d build ] || rm -rf build
-
- find . -name "*.pyc" -delete
-
- dh_clean build-stamp
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- NO_SETUPTOOLS=1 python setup.py -q install --no-compile \
- --root=$(CURDIR)/debian/python-logilab-common/ \
- # remove test directory
- rm -rf debian/python-logilab-common/usr/lib/python*/site-packages/logilab/common/test
-
-# Build architecture-independent files here.
-binary-indep: build install
- dh_testdir
- dh_testroot
- dh_install -i
- dh_pysupport -i
- dh_installchangelogs -i ChangeLog
- dh_installexamples -i
- dh_installdocs -i README doc/apidoc/
- dh_installman -i
- dh_link -i
- dh_compress -i -X.py -X.ini -X.xml -Xtest/ -Xapidoc/
- dh_fixperms -i
- dh_installdeb -i
- dh_gencontrol -i
- dh_md5sums -i
- dh_builddeb -i
-
-binary-arch:
-
-binary: binary-indep
-.PHONY: build clean binary binary-indep binary-arch