summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSylvain Th?nault <sylvain.thenault@logilab.fr>2013-07-26 11:28:18 +0200
committerSylvain Th?nault <sylvain.thenault@logilab.fr>2013-07-26 11:28:18 +0200
commit8f737a74b203442281bfb29330fdbd31bc9aba9b (patch)
tree5e0288d7c715515d5514e019cb0433cf494867f5
parentdca2e950453bf14cc1eb509effaa76f719f58a42 (diff)
downloadlogilab-common-8f737a74b203442281bfb29330fdbd31bc9aba9b.tar.gz
[packaging] fix regression introduced by aefd37dbb754 leading to crash when installing python3 version of the lib on a linux platformlogilab-common-version-0.60.0
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 8f27b3b..9ac5255 100644
--- a/setup.py
+++ b/setup.py
@@ -143,7 +143,7 @@ class MyBuildPy(build_py):
# brackets are NOT optional here for py3k compat
print('running 2to3 on', dest)
# Needs `shell=True` to run on Windows.
- check_call(['2to3', '-wn', dest], shell=True)
+ check_call(['2to3', '-wn', dest], shell=sys.platform=='win32')
def install(**kwargs):