summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Mueller <mmueller>2013-06-28 14:15:02 +0200
committerMike Mueller <mmueller>2013-06-28 14:15:02 +0200
commit84ba539413f84d320a4a59db95d38361b054383e (patch)
treec0d850b0a25aecb26048ebe93e8a54b83f59f94d
parent081bd4dae7a4c725984d7ffcc5f8de58f8a92fe3 (diff)
downloadlogilab-common-84ba539413f84d320a4a59db95d38361b054383e.tar.gz
Fixed: Install fails on Windows with Python 3.3. Calling subprocess with
`shell=True` works.
-rw-r--r--setup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index cc54251..8f27b3b 100644
--- a/setup.py
+++ b/setup.py
@@ -140,8 +140,10 @@ class MyBuildPy(build_py):
if sys.version_info >= (3, 0):
# process manually python file in include_dirs (test data)
from subprocess import check_call
- print('running 2to3 on', dest) # brackets are NOT optional here for py3k compat
- check_call(['2to3', '-wn', dest])
+ # brackets are NOT optional here for py3k compat
+ print('running 2to3 on', dest)
+ # Needs `shell=True` to run on Windows.
+ check_call(['2to3', '-wn', dest], shell=True)
def install(**kwargs):