summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSylvain Th?nault <sylvain.thenault@logilab.fr>2013-04-11 11:15:04 +0200
committerSylvain Th?nault <sylvain.thenault@logilab.fr>2013-04-11 11:15:04 +0200
commit6051b5918c3d1d7120f3d546410c937c3a2b0c09 (patch)
tree2a74d0044a1a8e7a56dbfcdb58e6c06703c480dd
parentee3a7c45f3bf5e515f355f5d90a4c53753a6cf1f (diff)
downloadlogilab-common-6051b5918c3d1d7120f3d546410c937c3a2b0c09.tar.gz
run 2to3 on test data files. Closes #120897
-rw-r--r--setup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 47cca43..cc54251 100644
--- a/setup.py
+++ b/setup.py
@@ -137,6 +137,11 @@ class MyBuildPy(build_py):
dest = join(basedir, directory)
shutil.rmtree(dest, ignore_errors=True)
shutil.copytree(directory, dest)
+ if sys.version_info >= (3, 0):
+ # process manually python file in include_dirs (test data)
+ from subprocess import check_call
+ print('running 2to3 on', dest) # brackets are NOT optional here for py3k compat
+ check_call(['2to3', '-wn', dest])
def install(**kwargs):