summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Jehannet <julien.jehannet@logilab.fr>2009-09-15 15:01:53 +0200
committerJulien Jehannet <julien.jehannet@logilab.fr>2009-09-15 15:01:53 +0200
commit028ddb178ec0276bd03b4b9694c3faf1d715a9dd (patch)
treead716de21d565adb568366c0f5ad472aae5f3395
parent31f761f57d265e133233b7e46d5cee6df2c71b13 (diff)
downloadlogilab-common-028ddb178ec0276bd03b4b9694c3faf1d715a9dd.tar.gz
[C] debian: refactoring and merge specific cases into unique debian directory
-rw-r--r--debian.hardy/control34
-rwxr-xr-xdebian.hardy/rules78
-rw-r--r--debian.intrepid/control39
-rwxr-xr-xdebian.intrepid/rules82
-rw-r--r--debian.jaunty/control34
-rwxr-xr-xdebian.jaunty/rules81
-rwxr-xr-xdebian.lenny/rules73
-rw-r--r--debian.stable/control39
-rwxr-xr-xdebian.stable/rules82
-rwxr-xr-xdebian/rules7
-rw-r--r--doc/makefile2
-rw-r--r--setup.py8
12 files changed, 13 insertions, 546 deletions
diff --git a/debian.hardy/control b/debian.hardy/control
deleted file mode 100644
index 481c76f..0000000
--- a/debian.hardy/control
+++ /dev/null
@@ -1,34 +0,0 @@
-Source: logilab-common
-Section: python
-Priority: optional
-Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
-Uploaders: David Douard <david.douard@logilab.fr>, Fabrice Douchant <fabrice.douchant@logilab.fr>, Alexandre Fayolle <afayolle@debian.org>, Sandro Tosi <morph@debian.org>, Dorothe Sénéchal <dorothee.senechal@logilab.fr>, Adrien Di Mascio <Adrien.DiMascio@logilab.fr>
-Build-Depends: debhelper (>= 5.0.38), python (>= 2.3.5-7)
-Build-Depends-Indep: python-support, python-epydoc, graphviz
-XS-Python-Version: all
-Standards-Version: 3.7
-Homepage: http://www.logilab.org/project/logilab-common
-Vcs-Svn: svn://svn.debian.org/svn/python-modules/packages/logilab-common/trunk/
-Vcs-Browser: http://svn.debian.org/viewsvn/python-modules/packages/logilab-common/trunk/
-
-Package: python-logilab-common
-Architecture: all
-Provides: ${python:Provides}
-Depends: ${python:Depends}, ${misc:Depends}
-Recommends: python-egenix-mxdatetime
-Conflicts: python-constraint ( <= 0.3.0-4), python-logilab-astng ( <= 0.16.0-1), pylint ( << 0.11.0-1), devtools ( <= 0.9.0-1), logilab-doctools ( <= 0.1.6-4), python-logilab-aspects ( <= 0.1.4-2), python2.3-logilab-common, python2.4-logilab-common
-XB-Python-Version: ${python:Versions}
-Description: useful miscellaneous modules used by Logilab projects
- logilab-common is a collection of low-level Python packages and modules,
- designed to ease:
- .
- * handling command line options and configuration files
- * writing interactive command line tools
- * manipulation files and character strings
- * interfacing to OmniORB
- * generating of SQL queries
- * running unit tests
- * manipulating tree structures
- * accessing RDBMS (currently postgreSQL, MySQL and sqlite)
- * generating text and HTML reports
- * logging
diff --git a/debian.hardy/rules b/debian.hardy/rules
deleted file mode 100755
index 0ae2f44..0000000
--- a/debian.hardy/rules
+++ /dev/null
@@ -1,78 +0,0 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-#
-# adapted by Logilab for automatic generation by debianize
-# (part of the devtools project, http://www.logilab.org/projects/devtools)
-#
-# Copyright (c) 2003-2008 LOGILAB S.A. (Paris, FRANCE).
-# http://www.logilab.fr/ -- mailto:contact@logilab.fr
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-build: build-stamp
-build-stamp:
- dh_testdir
-
- # python module build
- NO_SETUPTOOLS=1 python setup.py -q build
-
- # run tests
-ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
- # we need this hack because we have to import "logilab.common.pytest"
- # but since it's a namespace package, we need to "simulate" it
- touch $(CURDIR)/build/lib/logilab/__init__.py
- -PYTHONPATH=$(CURDIR)/build/lib/ $(CURDIR)/build/scripts-2.5/pytest
- rm -f $(CURDIR)/build/lib/logilab/__init__.py
-endif
-
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
-
- # clean doc
- $(MAKE) -C doc clean
-
- NO_SETUPTOOLS=1 python setup.py clean
-
- [ ! -d build ] || rm -rf build
-
- find . -name "*.pyc" -delete
-
- dh_clean build-stamp
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- NO_SETUPTOOLS=1 python setup.py -q install --no-compile --root=debian/python-logilab-common/ --install-headers=usr/include/ --install-scripts=usr/bin/
- # remove test directory
- rm -rf debian/python-logilab-common/usr/lib/python*/site-packages/logilab/common/test
-
-# Build architecture-independent files here.
-binary-indep: build install
- dh_testdir
- dh_testroot
- dh_install -i
- dh_pysupport -i
- dh_installchangelogs -i ChangeLog
- dh_installexamples -i
- dh_installdocs -i README
- dh_installman -i
- dh_link -i
- dh_compress -i -X.py -X.ini -X.xml -Xtest/
- dh_fixperms -i
- dh_installdeb -i
- dh_gencontrol -i
- dh_md5sums -i
- dh_builddeb -i
-
-binary-arch:
-
-binary: binary-indep
-.PHONY: build clean binary binary-indep binary-arch
diff --git a/debian.intrepid/control b/debian.intrepid/control
deleted file mode 100644
index 80fafda..0000000
--- a/debian.intrepid/control
+++ /dev/null
@@ -1,39 +0,0 @@
-Source: logilab-common
-Section: python
-Priority: optional
-Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
-Uploaders: David Douard <david.douard@logilab.fr>,
- Alexandre Fayolle <afayolle@debian.org>,
- Sandro Tosi <morph@debian.org>,
- Dorothe Sénéchal <dorothee.senechal@logilab.fr>,
- Adrien Di Mascio <Adrien.DiMascio@logilab.fr>,
- Nicolas Chauvat <nicolas.chauvat@logilab.fr>
-Build-Depends: debhelper (>= 5.0.37.2), python (>= 2.4)
-Build-Depends-Indep: python-support, python-epydoc, graphviz
-XS-Python-Version: all
-Standards-Version: 3.8.1
-Homepage: http://www.logilab.org/project/logilab-common
-Vcs-Svn: svn://svn.debian.org/svn/python-modules/packages/logilab-common/trunk/
-Vcs-Browser: http://svn.debian.org/viewsvn/python-modules/packages/logilab-common/trunk/
-
-Package: python-logilab-common
-Architecture: all
-Provides: ${python:Provides}
-Depends: ${python:Depends}, ${misc:Depends}
-Recommends: python-egenix-mxdatetime
-Conflicts: python-constraint ( <= 0.3.0-4), python-logilab-astng ( <= 0.16.0-1), pylint ( << 0.11.0-1), devtools ( <= 0.9.0-1), logilab-doctools ( <= 0.1.6-4), python-logilab-aspects ( <= 0.1.4-2), python2.3-logilab-common, python2.4-logilab-common
-XB-Python-Version: ${python:Versions}
-Description: useful miscellaneous modules used by Logilab projects
- logilab-common is a collection of low-level Python packages and modules,
- designed to ease:
- .
- * handling command line options and configuration files
- * writing interactive command line tools
- * manipulation files and character strings
- * interfacing to OmniORB
- * generating of SQL queries
- * running unit tests
- * manipulating tree structures
- * accessing RDBMS (currently postgreSQL, MySQL and sqlite)
- * generating text and HTML reports
- * logging
diff --git a/debian.intrepid/rules b/debian.intrepid/rules
deleted file mode 100755
index 80739ef..0000000
--- a/debian.intrepid/rules
+++ /dev/null
@@ -1,82 +0,0 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-#
-# adapted by Logilab for automatic generation by debianize
-# (part of the devtools project, http://www.logilab.org/projects/devtools)
-#
-# Copyright (c) 2003-2008 LOGILAB S.A. (Paris, FRANCE).
-# http://www.logilab.fr/ -- mailto:contact@logilab.fr
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-build: build-stamp
-build-stamp:
- dh_testdir
-
- # python module build
- NO_SETUPTOOLS=1 python setup.py -q build
-
- # run tests
-ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
- # we need this hack because we have to import "logilab.common.pytest"
- # but since it's a namespace package, we need to "simulate" it
- touch $(CURDIR)/build/lib/logilab/__init__.py
- PYTHONPATH=$(CURDIR)/build/lib/ $(CURDIR)/build/scripts-2.5/pytest
- rm -f $(CURDIR)/build/lib/logilab/__init__.py
-endif
-
- # build doc
- $(MAKE) -C doc
-
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
-
- # clean doc
- $(MAKE) -C doc clean
-
- NO_SETUPTOOLS=1 python setup.py clean
-
- [ ! -d build ] || rm -rf build
-
- find . -name "*.pyc" -delete
-
- dh_clean build-stamp
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- NO_SETUPTOOLS=1 python setup.py -q install --no-compile \
- --root=$(CURDIR)/debian/python-logilab-common/
- # remove test directory
- rm -rf debian/python-logilab-common/usr/lib/python*/site-packages/logilab/common/test
-
-# Build architecture-independent files here.
-binary-indep: build install
- dh_testdir
- dh_testroot
- dh_install -i
- dh_pysupport -i
- dh_installchangelogs -i ChangeLog
- dh_installexamples -i
- dh_installdocs -i README doc/apidoc/
- dh_installman -i
- dh_link -i
- dh_compress -i -X.py -X.ini -X.xml -Xtest/ -Xapidoc/
- dh_fixperms -i
- dh_installdeb -i
- dh_gencontrol -i
- dh_md5sums -i
- dh_builddeb -i
-
-binary-arch:
-
-binary: binary-indep
-.PHONY: build clean binary binary-indep binary-arch
diff --git a/debian.jaunty/control b/debian.jaunty/control
deleted file mode 100644
index 75cddac..0000000
--- a/debian.jaunty/control
+++ /dev/null
@@ -1,34 +0,0 @@
-Source: logilab-common
-Section: python
-Priority: optional
-Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
-Uploaders: David Douard <david.douard@logilab.fr>, Fabrice Douchant <fabrice.douchant@logilab.fr>, Alexandre Fayolle <afayolle@debian.org>, Sandro Tosi <morph@debian.org>, Dorothe Sénéchal <dorothee.senechal@logilab.fr>, Adrien Di Mascio <Adrien.DiMascio@logilab.fr>
-Build-Depends: debhelper (>= 5.0.38), python (>= 2.3.5-7)
-Build-Depends-Indep: python-support, python-epydoc, graphviz
-XS-Python-Version: all
-Standards-Version: 3.8.1
-Homepage: http://www.logilab.org/project/logilab-common
-Vcs-Svn: svn://svn.debian.org/svn/python-modules/packages/logilab-common/trunk/
-Vcs-Browser: http://svn.debian.org/viewsvn/python-modules/packages/logilab-common/trunk/
-
-Package: python-logilab-common
-Architecture: all
-Provides: ${python:Provides}
-Depends: ${python:Depends}, ${misc:Depends}
-Recommends: python-egenix-mxdatetime
-Conflicts: python-constraint ( <= 0.3.0-4), python-logilab-astng ( <= 0.16.0-1), pylint ( << 0.11.0-1), devtools ( <= 0.9.0-1), logilab-doctools ( <= 0.1.6-4), python-logilab-aspects ( <= 0.1.4-2), python2.3-logilab-common, python2.4-logilab-common
-XB-Python-Version: ${python:Versions}
-Description: useful miscellaneous modules used by Logilab projects
- logilab-common is a collection of low-level Python packages and modules,
- designed to ease:
- .
- * handling command line options and configuration files
- * writing interactive command line tools
- * manipulation files and character strings
- * interfacing to OmniORB
- * generating of SQL queries
- * running unit tests
- * manipulating tree structures
- * accessing RDBMS (currently postgreSQL, MySQL and sqlite)
- * generating text and HTML reports
- * logging
diff --git a/debian.jaunty/rules b/debian.jaunty/rules
deleted file mode 100755
index f1f9362..0000000
--- a/debian.jaunty/rules
+++ /dev/null
@@ -1,81 +0,0 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-#
-# adapted by Logilab for automatic generation by debianize
-# (part of the devtools project, http://www.logilab.org/projects/devtools)
-#
-# Copyright (c) 2003-2008 LOGILAB S.A. (Paris, FRANCE).
-# http://www.logilab.fr/ -- mailto:contact@logilab.fr
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-build: build-stamp
-build-stamp:
- dh_testdir
-
- # python module build
- NO_SETUPTOOLS=1 python setup.py -q build --build-purelib build/lib
-
- # run tests
-ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
- # we need this hack because we have to import "logilab.common.pytest"
- # but since it's a namespace package, we need to "simulate" it
- touch $(CURDIR)/build/lib/logilab/__init__.py
- -PYTHONPATH=$(CURDIR)/build/lib/ $(CURDIR)/build/scripts-2.6/pytest
- rm -f $(CURDIR)/build/lib/logilab/__init__.py
-endif
-
- # build doc
- $(MAKE) -C doc
-
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
-
- # clean doc
- $(MAKE) -C doc clean
-
- NO_SETUPTOOLS=1 python setup.py clean
-
- [ ! -d build ] || rm -rf build
-
- find . -name "*.pyc" -delete
-
- dh_clean build-stamp
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- NO_SETUPTOOLS=1 python setup.py -q install --no-compile --root=debian/python-logilab-common/ --install-headers=usr/include/ --install-scripts=usr/bin/
- # remove test directory
- rm -rf debian/python-logilab-common/usr/lib/python*/site-packages/logilab/common/test
-
-# Build architecture-independent files here.
-binary-indep: build install
- dh_testdir
- dh_testroot
- dh_install -i
- dh_pysupport -i
- dh_installchangelogs -i ChangeLog
- dh_installexamples -i
- dh_installdocs -i README doc/apidoc/
- dh_installman -i
- dh_link -i
- dh_compress -i -X.py -X.ini -X.xml -Xtest/ -Xapidoc/
- dh_fixperms -i
- dh_installdeb -i
- dh_gencontrol -i
- dh_md5sums -i
- dh_builddeb -i
-
-binary-arch:
-
-binary: binary-indep
-.PHONY: build clean binary binary-indep binary-arch
diff --git a/debian.lenny/rules b/debian.lenny/rules
deleted file mode 100755
index f468406..0000000
--- a/debian.lenny/rules
+++ /dev/null
@@ -1,73 +0,0 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-#
-# adapted by Logilab for automatic generation by debianize
-# (part of the devtools project, http://www.logilab.org/projects/devtools)
-#
-# Copyright (c) 2003-2008 LOGILAB S.A. (Paris, FRANCE).
-# http://www.logilab.fr/ -- mailto:contact@logilab.fr
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-build: build-stamp
-build-stamp:
- dh_testdir
-
- # python module build
- NO_SETUPTOOLS=1 python setup.py -q build
-
- # build doc
- $(MAKE) -C doc
-
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
-
- # clean doc
- $(MAKE) -C doc clean
-
- NO_SETUPTOOLS=1 python setup.py clean
-
- [ ! -d build ] || rm -rf build
-
- find . -name "*.pyc" -delete
-
- dh_clean build-stamp
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- NO_SETUPTOOLS=1 python setup.py -q install --no-compile \
- --root=$(CURDIR)/debian/python-logilab-common/ \
- # remove test directory
- rm -rf debian/python-logilab-common/usr/lib/python*/site-packages/logilab/common/test
-
-# Build architecture-independent files here.
-binary-indep: build install
- dh_testdir
- dh_testroot
- dh_install -i
- dh_pysupport -i
- dh_installchangelogs -i ChangeLog
- dh_installexamples -i
- dh_installdocs -i README doc/apidoc/
- dh_installman -i
- dh_link -i
- dh_compress -i -X.py -X.ini -X.xml -Xtest/ -Xapidoc/
- dh_fixperms -i
- dh_installdeb -i
- dh_gencontrol -i
- dh_md5sums -i
- dh_builddeb -i
-
-binary-arch:
-
-binary: binary-indep
-.PHONY: build clean binary binary-indep binary-arch
diff --git a/debian.stable/control b/debian.stable/control
deleted file mode 100644
index 80fafda..0000000
--- a/debian.stable/control
+++ /dev/null
@@ -1,39 +0,0 @@
-Source: logilab-common
-Section: python
-Priority: optional
-Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
-Uploaders: David Douard <david.douard@logilab.fr>,
- Alexandre Fayolle <afayolle@debian.org>,
- Sandro Tosi <morph@debian.org>,
- Dorothe Sénéchal <dorothee.senechal@logilab.fr>,
- Adrien Di Mascio <Adrien.DiMascio@logilab.fr>,
- Nicolas Chauvat <nicolas.chauvat@logilab.fr>
-Build-Depends: debhelper (>= 5.0.37.2), python (>= 2.4)
-Build-Depends-Indep: python-support, python-epydoc, graphviz
-XS-Python-Version: all
-Standards-Version: 3.8.1
-Homepage: http://www.logilab.org/project/logilab-common
-Vcs-Svn: svn://svn.debian.org/svn/python-modules/packages/logilab-common/trunk/
-Vcs-Browser: http://svn.debian.org/viewsvn/python-modules/packages/logilab-common/trunk/
-
-Package: python-logilab-common
-Architecture: all
-Provides: ${python:Provides}
-Depends: ${python:Depends}, ${misc:Depends}
-Recommends: python-egenix-mxdatetime
-Conflicts: python-constraint ( <= 0.3.0-4), python-logilab-astng ( <= 0.16.0-1), pylint ( << 0.11.0-1), devtools ( <= 0.9.0-1), logilab-doctools ( <= 0.1.6-4), python-logilab-aspects ( <= 0.1.4-2), python2.3-logilab-common, python2.4-logilab-common
-XB-Python-Version: ${python:Versions}
-Description: useful miscellaneous modules used by Logilab projects
- logilab-common is a collection of low-level Python packages and modules,
- designed to ease:
- .
- * handling command line options and configuration files
- * writing interactive command line tools
- * manipulation files and character strings
- * interfacing to OmniORB
- * generating of SQL queries
- * running unit tests
- * manipulating tree structures
- * accessing RDBMS (currently postgreSQL, MySQL and sqlite)
- * generating text and HTML reports
- * logging
diff --git a/debian.stable/rules b/debian.stable/rules
deleted file mode 100755
index 937f9df..0000000
--- a/debian.stable/rules
+++ /dev/null
@@ -1,82 +0,0 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-#
-# adapted by Logilab for automatic generation by debianize
-# (part of the devtools project, http://www.logilab.org/projects/devtools)
-#
-# Copyright (c) 2003-2008 LOGILAB S.A. (Paris, FRANCE).
-# http://www.logilab.fr/ -- mailto:contact@logilab.fr
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-build: build-stamp
-build-stamp:
- dh_testdir
-
- # python module build
- NO_SETUPTOOLS=1 python setup.py -q build
-
- # run tests
-ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
- # we need this hack because we have to import "logilab.common.pytest"
- # but since it's a namespace package, we need to "simulate" it
- touch $(CURDIR)/build/lib/logilab/__init__.py
- -PYTHONPATH=$(CURDIR)/build/lib/ $(CURDIR)/build/scripts-2.5/pytest
- rm -f $(CURDIR)/build/lib/logilab/__init__.py
-endif
-
- # build doc
- $(MAKE) -C doc
-
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
-
- # clean doc
- $(MAKE) -C doc clean
-
- NO_SETUPTOOLS=1 python setup.py clean
-
- [ ! -d build ] || rm -rf build
-
- find . -name "*.pyc" -delete
-
- dh_clean build-stamp
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- NO_SETUPTOOLS=1 python setup.py -q install --no-compile \
- --root=$(CURDIR)/debian/python-logilab-common/
- # remove test directory
- rm -rf debian/python-logilab-common/usr/lib/python*/site-packages/logilab/common/test
-
-# Build architecture-independent files here.
-binary-indep: build install
- dh_testdir
- dh_testroot
- dh_install -i
- dh_pysupport -i
- dh_installchangelogs -i ChangeLog
- dh_installexamples -i
- dh_installdocs -i README doc/apidoc/
- dh_installman -i
- dh_link -i
- dh_compress -i -X.py -X.ini -X.xml -Xtest/ -Xapidoc/
- dh_fixperms -i
- dh_installdeb -i
- dh_gencontrol -i
- dh_md5sums -i
- dh_builddeb -i
-
-binary-arch:
-
-binary: binary-indep
-.PHONY: build clean binary binary-indep binary-arch
diff --git a/debian/rules b/debian/rules
index c0bd75a..e1acbe2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,20 +10,21 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+PY_VERSION:=$(shell pyversions -vd)
build: build-stamp
build-stamp:
dh_testdir
# python module build
- NO_SETUPTOOLS=1 python setup.py -q build
+ NO_SETUPTOOLS=1 python setup.py -q build --build-purelib=build/lib
# run tests
ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
# we need this hack because we have to import "logilab.common.pytest"
# but since it's a namespace package, we need to "simulate" it
touch $(CURDIR)/build/lib/logilab/__init__.py
- -PYTHONPATH=$(CURDIR)/build/lib/ $(CURDIR)/build/scripts-2.5/pytest
+ -PYTHONPATH=$(CURDIR)/build/lib/ $(CURDIR)/build/scripts-$(PY_VERSION)/pytest
rm -f $(CURDIR)/build/lib/logilab/__init__.py
endif
@@ -53,7 +54,7 @@ install: build
dh_clean -k
dh_installdirs
- NO_SETUPTOOLS=1 python setup.py -q install --no-compile \
+ NO_SETUPTOOLS=1 python setup.py -q install --prefix=/usr --no-compile \
--root=$(CURDIR)/debian/python-logilab-common/ \
--install-layout=deb
# remove test directory
diff --git a/doc/makefile b/doc/makefile
index ddea5d5..2484e55 100644
--- a/doc/makefile
+++ b/doc/makefile
@@ -3,7 +3,7 @@ all: epydoc
epydoc:
#epydoc -o apidoc --html -v --graph all --no-private --exclude="__pkginfo__" --exclude="setup" -n "Logilab's common library" ../
mkdir apidoc
- epydoc -o apidoc --html -v --no-private --exclude="__pkginfo__" --exclude="setup" -n "Logilab's common library" ../
+ epydoc -o apidoc --html -v --no-private --exclude="__pkginfo__" --exclude="setup" -n "Logilab's common library" $(shell dirname $(CURDIR))/build/lib/logilab/common
clean:
rm -rf apidoc
diff --git a/setup.py b/setup.py
index b159394..e86391d 100644
--- a/setup.py
+++ b/setup.py
@@ -174,6 +174,14 @@ def install(**kwargs):
sys.argv.remove('--force-manifest')
except:
pass
+ try:
+ if not USE_SETUPTOOLS:
+ from distutils import __version__ as distutils_version
+ if distutils_version.split('.') <= (2, 5, 1):
+ sys.argv.remove('--install-layout=deb')
+ print "W: remove '--install-layout=deb' option"
+ except:
+ pass
if subpackage_of:
package = subpackage_of + '.' + modname
kwargs['package_dir'] = {package : '.'}