summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--setup.cfg3
-rw-r--r--tox.ini2
3 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 5dc04cd8..fbf715d7 100644
--- a/Makefile
+++ b/Makefile
@@ -98,7 +98,7 @@ flakeplusdiag:
-$(MAKE) flakepluscheck
pep257check:
- $(PYDOCSTYLE) --ignore=D102,D104,D203,D105 "$(PROJ)"
+ $(PYDOCSTYLE) "$(PROJ)"
flakes: flakediag flakeplusdiag pep257check
diff --git a/setup.cfg b/setup.cfg
index b4362123..041fefdd 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -12,6 +12,9 @@ all_files = 1
# whenever it makes the code more readable.
ignore = N806, N802, N801, N803
+[pep257]
+ignore = D102,D104,D203,D105
+
[bdist_rpm]
requires = amqp >= 1.4.5
diff --git a/tox.ini b/tox.ini
index 25541697..54bb0281 100644
--- a/tox.ini
+++ b/tox.ini
@@ -57,4 +57,4 @@ commands =
[testenv:pydocstyle]
commands =
- pydocstyle --ignore=D102,D104,D203,D105 kombu
+ pydocstyle {toxinidir}/kombu