summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAsk Solem <ask@celeryproject.org>2012-05-28 21:15:11 +0100
committerAsk Solem <ask@celeryproject.org>2012-05-28 21:15:11 +0100
commit2d23d22c83cfef65473e9588e10a385abb6c24d2 (patch)
tree171f7dfb50a5bb84aa57331368979ff5b7c1bb9a /setup.py
parent88cf7726a668e958d84905aa6525297f98318610 (diff)
downloadkombu-2d23d22c83cfef65473e9588e10a385abb6c24d2.tar.gz
Don't depend on librabbitmq afterall
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 4 insertions, 12 deletions
diff --git a/setup.py b/setup.py
index 7308f844..5ebcc13e 100644
--- a/setup.py
+++ b/setup.py
@@ -100,17 +100,6 @@ if os.path.exists("README.rst"):
else:
long_description = "See http://pypi.python.org/pypi/kombu"
-install_requires = ["anyjson>=0.3.1"]
-
-is_jython = sys.platform.startswith("java")
-is_pypy = hasattr(sys, "pypy_version_info")
-is_py3k = sys.version_info[0] == 3
-is_win = platform.system() == "Windows"
-if is_jython or is_pypy or is_py3k or is_win:
- install_requires.append("amqplib>=1.0.1")
-else:
- install_requires.append("librabbitmq>=0.9.3")
-
setup(
name='kombu',
version=meta["VERSION"],
@@ -123,7 +112,10 @@ setup(
data_files=data_files,
zip_safe=False,
test_suite="nose.collector",
- install_requires=install_requires,
+ install_requires=[
+ "anyjson>=0.3.1",
+ "amqplib>=1.0.2",
+ ],
tests_require=tests_require,
classifiers=[
"Development Status :: 5 - Production/Stable",