summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAsk Solem <ask@celeryproject.org>2012-05-22 19:50:58 +0100
committerAsk Solem <ask@celeryproject.org>2012-05-22 19:50:58 +0100
commit4300eff0e99bef62fcf978b033a6dc7be51986d7 (patch)
tree263e14c5f8319cbf2e6cf679a3c5ce7c24f66528 /setup.py
parent60d8ac1fbc6f6055c8f7346cd335cbe25fa4fbef (diff)
downloadkombu-4300eff0e99bef62fcf978b033a6dc7be51986d7.tar.gz
Install librabbitmq if supported, and amqp points to lrmq if installed
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 12 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 1dbe27eb..7308f844 100644
--- a/setup.py
+++ b/setup.py
@@ -100,6 +100,17 @@ if os.path.exists("README.rst"):
else:
long_description = "See http://pypi.python.org/pypi/kombu"
+install_requires = ["anyjson>=0.3.1"]
+
+is_jython = sys.platform.startswith("java")
+is_pypy = hasattr(sys, "pypy_version_info")
+is_py3k = sys.version_info[0] == 3
+is_win = platform.system() == "Windows"
+if is_jython or is_pypy or is_py3k or is_win:
+ install_requires.append("amqplib>=1.0.1")
+else:
+ install_requires.append("librabbitmq>=0.9.3")
+
setup(
name='kombu',
version=meta["VERSION"],
@@ -112,10 +123,7 @@ setup(
data_files=data_files,
zip_safe=False,
test_suite="nose.collector",
- install_requires=[
- 'anyjson>=0.3.1',
- 'amqplib>=1.0',
- ],
+ install_requires=install_requires,
tests_require=tests_require,
classifiers=[
"Development Status :: 5 - Production/Stable",