summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorWido den Hollander <wido@widodh.nl>2016-04-11 14:56:58 +0200
committerAsk Solem <ask@celeryproject.org>2016-06-15 17:41:32 -0700
commit551d92014d09f43ea30f0a3ff7ea6af3eb764a1e (patch)
treefce8e9ae49b61795fb37a56858fe47700981cc70 /setup.py
parentad45023e821d21fe52e8328a0d85336794ed555d (diff)
downloadkombu-551d92014d09f43ea30f0a3ff7ea6af3eb764a1e.tar.gz
Add Consul K/V store Transport
Using the Key/Value store of Consul.io this commit adds a new Transport. It is a simple Transport which Messages as Keys in the K/V store of Consul using the HTTP API. The HTTP API is consumed using the python-consul client which exposes the API in a Python way.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 0d522e11..410348e1 100644
--- a/setup.py
+++ b/setup.py
@@ -165,5 +165,6 @@ setup(
'pyro': extras('pyro.txt'),
'slmq': extras('slmq.txt'),
'qpid': extras('qpid.txt'),
+ 'consul': extras('consul.txt'),
},
)