summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorClemens Wolff <clemens@justamouse.com>2018-08-30 12:34:52 -0500
committerAsif Saifuddin Auvi <auvipy@gmail.com>2018-08-30 23:34:52 +0600
commit32633554ac0a5f15f66c648b952d14cc1eab14b2 (patch)
tree15867e48dcfd256a7048f5aa6900e4722bac031c /setup.py
parent200a60a228bd836542e9e9a2759af1d915139d1c (diff)
downloadkombu-32633554ac0a5f15f66c648b952d14cc1eab14b2.tar.gz
Add transports based on Azure PaaS (#891)
* Add transports based on Azure PaaS This pull request adds two new transport implementations: - `azurestoragequeues` is implemented on top of Azure Storage Queues [1]. This offers a simple but scalable and low-cost PaaS transport for Celery users in Azure. The transport is intended to be used in conjunction with the Azure Block Blob Storage backend [2]. - `azureservicebus` is implemented on top of Azure Service Bus [3] and offers PaaS support for more demanding Celery workloads in Azure. The transport is intended to be used in conjunction with the Azure CosmosDB backend [4]. This pull request was created together with @ankurokok, @dkisselev, @evandropaula, @martinpeck and @michaelperel. [1] https://azure.microsoft.com/en-us/services/storage/queues/ [2] https://github.com/celery/celery/pull/4685 [3] https://azure.microsoft.com/en-us/services/service-bus/ [4] https://github.com/celery/celery/pull/4720 * Exclude Azure transports from code coverage There is test coverage for the transports but the tests require Azure credentials to run (passed via environment variables) so codecov doesn't exercise them. * Remove env vars to configure transport * Remove abbreviations
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 77c35913..dac04d7e 100644
--- a/setup.py
+++ b/setup.py
@@ -130,6 +130,8 @@ setup(
'librabbitmq': extras('librabbitmq.txt'),
'pyro': extras('pyro.txt'),
'slmq': extras('slmq.txt'),
+ 'azurestoragequeues': extras('azurestoragequeues.txt'),
+ 'azureservicebus': extras('azureservicebus.txt'),
'qpid': extras('qpid.txt'),
'consul': extras('consul.txt'),
},