summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAsk Solem <ask@celeryproject.org>2012-11-12 15:56:30 +0000
committerAsk Solem <ask@celeryproject.org>2012-11-12 15:56:30 +0000
commitc1e06243d0ffb5fda664f15db1da4d53540ebdfb (patch)
tree93dfa90bb3cad5c4ce86a9feaa4c4c2079cb2fbd /setup.py
parent9052d0fd7226b1f377b6fd906c8c0b8459fdea44 (diff)
downloadkombu-c1e06243d0ffb5fda664f15db1da4d53540ebdfb.tar.gz
[3.0] Requires Python 2.6 or higher
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 3dbebc00..cf4c9b61 100644
--- a/setup.py
+++ b/setup.py
@@ -7,8 +7,8 @@ import codecs
extra = {}
PY3 = sys.version_info[0] == 3
-if sys.version_info < (2, 4):
- raise Exception('Kombu requires Python 2.4 or higher.')
+if sys.version_info < (2, 6):
+ raise Exception('Kombu requires Python 2.6 or higher.')
try:
from setuptools import setup
@@ -138,9 +138,10 @@ setup(
'Operating System :: OS Independent',
'Programming Language :: Python',
'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 2.6',
- 'Programming Language :: Python :: 2.5',
'Programming Language :: Python :: 2',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',