summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpre-commit-ci[bot] <66853113+pre-commit-ci[bot]@users.noreply.github.com>2021-09-27 21:35:17 +0300
committerGitHub <noreply@github.com>2021-09-27 21:35:17 +0300
commitee99595232a60097d816ab3f65510b8057ab364e (patch)
tree61c34662f1526adc8f0382055e73438f6f51ba5e
parent580b5219cc50cad278c4b664d0e0f85e37a5e9ea (diff)
downloadkombu-ee99595232a60097d816ab3f65510b8057ab364e.tar.gz
[pre-commit.ci] pre-commit autoupdate (#1393)
* [pre-commit.ci] pre-commit autoupdate updates: - [github.com/asottile/pyupgrade: v2.26.0 → v2.28.0](https://github.com/asottile/pyupgrade/compare/v2.26.0...v2.28.0) * [pre-commit.ci] auto fixes from pre-commit.com hooks for more information, see https://pre-commit.ci Co-authored-by: pre-commit-ci[bot] <66853113+pre-commit-ci[bot]@users.noreply.github.com>
-rw-r--r--.pre-commit-config.yaml2
-rw-r--r--kombu/asynchronous/aws/connection.py2
-rw-r--r--kombu/asynchronous/aws/sqs/connection.py3
-rw-r--r--kombu/log.py2
-rw-r--r--kombu/utils/collections.py6
-rw-r--r--setup.py2
-rw-r--r--t/unit/test_common.py2
-rw-r--r--t/unit/test_pools.py2
-rw-r--r--t/unit/transport/virtual/test_exchange.py4
9 files changed, 12 insertions, 13 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 56a60482..a94c9da9 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -1,6 +1,6 @@
repos:
- repo: https://github.com/asottile/pyupgrade
- rev: v2.26.0
+ rev: v2.28.0
hooks:
- id: pyupgrade
args: ["--py36-plus"]
diff --git a/kombu/asynchronous/aws/connection.py b/kombu/asynchronous/aws/connection.py
index 6f087e8f..c3e45c87 100644
--- a/kombu/asynchronous/aws/connection.py
+++ b/kombu/asynchronous/aws/connection.py
@@ -177,7 +177,7 @@ class AsyncAWSQueryConnection(AsyncConnection):
http_client_params=None, **kwargs):
if not http_client_params:
http_client_params = {}
- AsyncConnection.__init__(self, sqs_connection, http_client,
+ super().__init__(sqs_connection, http_client,
**http_client_params)
def make_request(self, operation, params_, path, verb, callback=None): # noqa
diff --git a/kombu/asynchronous/aws/sqs/connection.py b/kombu/asynchronous/aws/sqs/connection.py
index 0a524ba0..9db2523b 100644
--- a/kombu/asynchronous/aws/sqs/connection.py
+++ b/kombu/asynchronous/aws/sqs/connection.py
@@ -17,8 +17,7 @@ class AsyncSQSConnection(AsyncAWSQueryConnection):
def __init__(self, sqs_connection, debug=0, region=None, **kwargs):
if boto3 is None:
raise ImportError('boto3 is not installed')
- AsyncAWSQueryConnection.__init__(
- self,
+ super().__init__(
sqs_connection,
region_name=region, debug=debug,
**kwargs
diff --git a/kombu/log.py b/kombu/log.py
index a29aadaa..de77e7f3 100644
--- a/kombu/log.py
+++ b/kombu/log.py
@@ -115,7 +115,7 @@ class Log(LogMixin):
def get_logger(self):
if self._logger:
return self._logger
- return LogMixin.get_logger(self)
+ return super().get_logger()
@property
def logger_name(self):
diff --git a/kombu/utils/collections.py b/kombu/utils/collections.py
index 0ee27399..77781047 100644
--- a/kombu/utils/collections.py
+++ b/kombu/utils/collections.py
@@ -33,10 +33,10 @@ class EqualityDict(dict):
h = eqhash(key)
if h not in self:
return self.__missing__(key)
- return dict.__getitem__(self, h)
+ return super().__getitem__(h)
def __setitem__(self, key, value):
- return dict.__setitem__(self, eqhash(key), value)
+ return super().__setitem__(eqhash(key), value)
def __delitem__(self, key):
- return dict.__delitem__(self, eqhash(key))
+ return super().__delitem__(eqhash(key))
diff --git a/setup.py b/setup.py
index e1bf1cd4..293cc86a 100644
--- a/setup.py
+++ b/setup.py
@@ -86,7 +86,7 @@ class pytest(setuptools.command.test.test):
user_options = [('pytest-args=', 'a', 'Arguments to pass to py.test')]
def initialize_options(self):
- setuptools.command.test.test.initialize_options(self)
+ super().initialize_options()
self.pytest_args = []
def run_tests(self):
diff --git a/t/unit/test_common.py b/t/unit/test_common.py
index c99bcb0d..0f669b7d 100644
--- a/t/unit/test_common.py
+++ b/t/unit/test_common.py
@@ -396,7 +396,7 @@ class test_QoS:
class _QoS(QoS):
def __init__(self, value):
self.value = value
- QoS.__init__(self, None, value)
+ super().__init__(None, value)
def set(self, value):
return value
diff --git a/t/unit/test_pools.py b/t/unit/test_pools.py
index 9f33f4b8..eb2a556e 100644
--- a/t/unit/test_pools.py
+++ b/t/unit/test_pools.py
@@ -14,7 +14,7 @@ class test_ProducerPool:
def __init__(self, *args, **kwargs):
self.instance = Mock()
- pools.ProducerPool.__init__(self, *args, **kwargs)
+ super().__init__(*args, **kwargs)
def Producer(self, connection):
return self.instance
diff --git a/t/unit/transport/virtual/test_exchange.py b/t/unit/transport/virtual/test_exchange.py
index ac0a8b68..55741445 100644
--- a/t/unit/transport/virtual/test_exchange.py
+++ b/t/unit/transport/virtual/test_exchange.py
@@ -69,7 +69,7 @@ class test_Topic(ExchangeCase):
]
def setup(self):
- ExchangeCase.setup(self)
+ super().setup()
self.table = [(rkey, self.e.key_to_pattern(rkey), queue)
for rkey, _, queue in self.table]
@@ -114,7 +114,7 @@ class test_TopicMultibind(ExchangeCase):
]
def setup(self):
- ExchangeCase.setup(self)
+ super().setup()
self.table = [(rkey, self.e.key_to_pattern(rkey), queue)
for rkey, _, queue in self.table]