summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2018-04-12 04:31:53 -0700
committerAsif Saifuddin Auvi <auvipy@gmail.com>2018-04-12 17:31:53 +0600
commitc9ea79f0f94a1d34dc6f8dc36f9f7471f6d840b9 (patch)
tree60557fed39931595f41bffe51a5bd53fce2314ba
parentb19bb3dd320ad4bfb6063e8154e1d80845654bc2 (diff)
downloadkombu-c9ea79f0f94a1d34dc6f8dc36f9f7471f6d840b9.tar.gz
Pass python_requires argument to setuptools (#847)
Helps pip decide what version of the library to install. https://packaging.python.org/tutorials/distributing-packages/#python-requires > If your project only runs on certain Python versions, setting the > python_requires argument to the appropriate PEP 440 version specifier > string will prevent pip from installing the project on other Python > versions. https://setuptools.readthedocs.io/en/latest/setuptools.html#new-and-changed-setup-keywords > python_requires > > A string corresponding to a version specifier (as defined in PEP 440) > for the Python version, used to specify the Requires-Python defined in > PEP 345.
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 21d7f8ab..d0e3ff3a 100644
--- a/setup.py
+++ b/setup.py
@@ -132,6 +132,7 @@ setup(
zip_safe=False,
license='BSD',
cmdclass={'test': pytest},
+ python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
install_requires=reqs('default.txt'),
tests_require=reqs('test.txt'),
extras_require={