summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichaƂ Bielawski <michal.bielawski@apperio.com>2021-07-30 13:54:04 +0100
committerAsif Saif Uddin <auvipy@gmail.com>2021-07-31 10:27:29 +0600
commit4f77faab77bafce288d2baa143e66d4ec870d2eb (patch)
tree5a5d80a0e17ceec8f277a29974b29dfcd91b508c
parent0234ea2d61502199a94278e1a53521e0e1a97c40 (diff)
downloadkombu-4f77faab77bafce288d2baa143e66d4ec870d2eb.tar.gz
Add support for Python 3.9
-rw-r--r--.github/workflows/ci.yaml6
-rw-r--r--setup.py1
-rw-r--r--tox.ini17
3 files changed, 13 insertions, 11 deletions
diff --git a/.github/workflows/ci.yaml b/.github/workflows/ci.yaml
index 7ba42dde..0a88ad2f 100644
--- a/.github/workflows/ci.yaml
+++ b/.github/workflows/ci.yaml
@@ -6,7 +6,7 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python-version: [3.6,3.7,3.8]
+ python-version: [3.6,3.7,3.8,3.9]
steps:
- name: Install system packages
run: sudo apt update && sudo apt-get install libcurl4-openssl-dev libssl-dev
@@ -27,7 +27,7 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python-version: [3.6,3.7,3.8,pypy3]
+ python-version: [3.6,3.7,3.8,3.9,pypy3]
steps:
- name: Install system packages
run: sudo apt update && sudo apt-get install libcurl4-openssl-dev libssl-dev
@@ -51,7 +51,7 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python-version: [3.8]
+ python-version: [3.9]
steps:
- name: Install system packages
run: sudo apt update && sudo apt-get install libcurl4-openssl-dev libssl-dev
diff --git a/setup.py b/setup.py
index 3a7ad0c9..e1bf1cd4 100644
--- a/setup.py
+++ b/setup.py
@@ -141,6 +141,7 @@ setup(
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Intended Audience :: Developers',
diff --git a/tox.ini b/tox.ini
index 11ed7aa7..ddfd8aab 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,8 +1,8 @@
[tox]
envlist =
- {pypy3,3.6,3.7,3.8}-unit
- {pypy3,3.6,3.7,3.8}-linux-integration-py-amqp
- {pypy3,3.6,3.7,3.8}-linux-integration-redis
+ {pypy3,3.6,3.7,3.8,3.9}-unit
+ {pypy3,3.6,3.7,3.8,3.9}-linux-integration-py-amqp
+ {pypy3,3.6,3.7,3.8,3.9}-linux-integration-redis
flake8
flakeplus
apicheck
@@ -17,10 +17,10 @@ passenv =
DISTUTILS_USE_SDK
deps=
-r{toxinidir}/requirements/dev.txt
- apicheck,pypy3,3.6,3.7,3.8: -r{toxinidir}/requirements/default.txt
- apicheck,pypy3,3.6,3.7,3.8: -r{toxinidir}/requirements/test.txt
- apicheck,pypy3,3.6,3.7-linux,3.8-linux: -r{toxinidir}/requirements/test-ci.txt
- 3.7-windows,3.8-windows: -r{toxinidir}/requirements/test-ci-windows.txt
+ apicheck,pypy3,3.6,3.7,3.8,3.9: -r{toxinidir}/requirements/default.txt
+ apicheck,pypy3,3.6,3.7,3.8,3.9: -r{toxinidir}/requirements/test.txt
+ apicheck,pypy3,3.6,3.7-linux,3.8-linux,3.9-linux: -r{toxinidir}/requirements/test-ci.txt
+ 3.7-windows,3.8-windows,3.9-windows: -r{toxinidir}/requirements/test-ci-windows.txt
apicheck,linkcheck: -r{toxinidir}/requirements/docs.txt
flake8,flakeplus,pydocstyle: -r{toxinidir}/requirements/pkgutils.txt
@@ -32,7 +32,8 @@ commands =
basepython =
3.6: python3.6
3.7: python3.7
- 3.8,apicheck,pydocstyle,flake8,linkcheck,cov: python3.8
+ 3.8: python3.8
+ 3.9,apicheck,pydocstyle,flake8,linkcheck,cov: python3.9
pypy3: pypy
install_command = python -m pip --disable-pip-version-check install {opts} {packages}