summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAsk Solem <ask@celeryproject.org>2011-03-28 14:42:38 +0200
committerAsk Solem <ask@celeryproject.org>2011-03-28 14:43:52 +0200
commitaf4339170d6161f84881f0d7ea305c018c0f9cb5 (patch)
tree6d21efd5d822a751f72e130faeb85e22df032c1d
parent59a06d25bc55fb665d4f3b898ed7c48fea9d50e6 (diff)
downloadkombu-af4339170d6161f84881f0d7ea305c018c0f9cb5.tar.gz
Now depends on anyjson 0.3.1 for the cjson deprecation
-rw-r--r--Changelog5
-rw-r--r--contrib/requirements/default.txt2
-rw-r--r--setup.cfg2
-rw-r--r--setup.py2
4 files changed, 8 insertions, 3 deletions
diff --git a/Changelog b/Changelog
index 6e4b5323..aba85bf4 100644
--- a/Changelog
+++ b/Changelog
@@ -6,6 +6,11 @@
=====
:release-date: 2011-03-28 16:00 P.M CEST
+* Now depends on anyjson 0.3.1
+
+ cjson is no longer a recommended json implementation, and anyjson
+ will now emit a deprecation warning if used.
+
* Please note that the Pika backend only works with version 0.5.2.
The latest version (0.9.x) drastically changed API, and it is not
diff --git a/contrib/requirements/default.txt b/contrib/requirements/default.txt
index 63c3428e..1b2372cb 100644
--- a/contrib/requirements/default.txt
+++ b/contrib/requirements/default.txt
@@ -1,2 +1,2 @@
-anyjson
+anyjson>=0.3.1
amqplib>=0.6
diff --git a/setup.cfg b/setup.cfg
index 1031f7dc..fba5ba9d 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -24,5 +24,5 @@ upload-dir = docs/.build/html
[bdist_rpm]
-requires = anyjson
+requires = anyjson >= 0.3.1
amqplib >= 0.6
diff --git a/setup.py b/setup.py
index 453a39fb..829b5a72 100644
--- a/setup.py
+++ b/setup.py
@@ -89,7 +89,7 @@ setup(
zip_safe=False,
test_suite="nose.collector",
install_requires=[
- 'anyjson',
+ 'anyjson>=0.3.1',
'amqplib>=0.6',
],
tests_require=tests_require,