summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Bangert <ben@groovie.org>2017-06-01 12:40:48 -0700
committerGitHub <noreply@github.com>2017-06-01 12:40:48 -0700
commitb0fbd357823ab8e526d065135eaf378e69975763 (patch)
treed17662334f1739720e74a434f9af71be57cf86a3
parent34954428324bca55dd339aa8b09a3377a46801cb (diff)
parent2faba9ff3bdeff151ac6c922bf65b2dcf9c7bd7b (diff)
downloadkazoo-b0fbd357823ab8e526d065135eaf378e69975763.tar.gz
Merge pull request #443 from python-zk/feat/issue-441
feat: drop Python 2.6/3.3 official support, add 3.5/3.6 testing
-rw-r--r--.travis.yml24
-rw-r--r--setup.py4
-rw-r--r--tox.ini13
3 files changed, 12 insertions, 29 deletions
diff --git a/.travis.yml b/.travis.yml
index 0c105d9..4feeb07 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -14,18 +14,6 @@ matrix:
exclude:
- python: '2.7'
include:
- - python: '2.6'
- env: ZOOKEEPER_VERSION=3.3.6 TOX_VENV=py26
- - python: '2.6'
- env: ZOOKEEPER_VERSION=3.4.10 TOX_VENV=py26
- - python: '2.6'
- env: ZOOKEEPER_VERSION=3.3.6 TOX_VENV=py26-gevent
- - python: '2.6'
- env: ZOOKEEPER_VERSION=3.4.10 TOX_VENV=py26-gevent
- - python: '2.6'
- env: ZOOKEEPER_VERSION=3.3.6 TOX_VENV=py26-eventlet
- - python: '2.6'
- env: ZOOKEEPER_VERSION=3.4.10 TOX_VENV=py26-eventlet
- python: '2.7'
env: ZOOKEEPER_VERSION=3.3.6 TOX_VENV=py27
- python: '2.7'
@@ -40,14 +28,18 @@ matrix:
env: ZOOKEEPER_VERSION=3.4.10 TOX_VENV=py27-eventlet
- python: '2.7'
env: ZOOKEEPER_VERSION=3.5.2-alpha TOX_VENV=py27
- - python: '3.3'
- env: ZOOKEEPER_VERSION=3.3.6 TOX_VENV=py33
- - python: '3.3'
- env: ZOOKEEPER_VERSION=3.4.10 TOX_VENV=py33
- python: '3.4'
env: ZOOKEEPER_VERSION=3.3.6 TOX_VENV=py34
- python: '3.4'
env: ZOOKEEPER_VERSION=3.4.10 TOX_VENV=py34
+ - python: '3.5'
+ env: ZOOKEEPER_VERSION=3.3.6 TOX_VENV=py35
+ - python: '3.5'
+ env: ZOOKEEPER_VERSION=3.4.10 TOX_VENV=py35
+ - python: '3.6'
+ env: ZOOKEEPER_VERSION=3.3.6 TOX_VENV=py36
+ - python: '3.6'
+ env: ZOOKEEPER_VERSION=3.4.10 TOX_VENV=py36
- python: pypy
env: ZOOKEEPER_VERSION=3.3.6 TOX_VENV=pypy
- python: pypy
diff --git a/setup.py b/setup.py
index 1af6113..a926129 100644
--- a/setup.py
+++ b/setup.py
@@ -52,11 +52,11 @@ setup(
"Operating System :: OS Independent",
"Programming Language :: Python",
"Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.3",
"Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
"Topic :: Communications",
diff --git a/tox.ini b/tox.ini
index f2aaed2..ffa4310 100644
--- a/tox.ini
+++ b/tox.ini
@@ -2,14 +2,13 @@
minversion = 1.6
skipsdist = True
envlist = pep8,
- py26,
- py26-gevent,
- py26-eventlet,
py27,
py27-gevent,
py27-eventlet,
py33,
py34,
+ py35,
+ py36,
pypy
[testenv:pep8]
@@ -33,14 +32,6 @@ deps = {[testenv]deps}
deps = {[testenv]deps}
-r{toxinidir}/requirements_eventlet.txt
-[testenv:py26-gevent]
-deps = {[testenv]deps}
- -r{toxinidir}/requirements_gevent.txt
-
-[testenv:py26-eventlet]
-deps = {[testenv]deps}
- -r{toxinidir}/requirements_eventlet.txt
-
[flake8]
builtins = _
exclude = .venv,.tox,dist,doc,*egg,.git,build,tools