summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Widman <jeff@jeffwidman.com>2017-07-24 16:03:43 -0600
committerGitHub <noreply@github.com>2017-07-24 16:03:43 -0600
commitf7c871a9013870c4e890c62612d9d4df5e2e089a (patch)
treec800abe16a2525251811071c108d631da524e3c7
parent5837d11bb541be1296e1b3c1842b11ceb7e743d4 (diff)
parent698873a6cbcef61615a0e39d09134eff1f367a94 (diff)
downloadkazoo-f7c871a9013870c4e890c62612d9d4df5e2e089a.tar.gz
Merge pull request #469 from python-zk/462-virtualenv-continued
chore: stop bundling virtualenv and assorted fixes
-rw-r--r--.gitignore1
-rw-r--r--.travis.yml2
-rw-r--r--Makefile10
-rw-r--r--kazoo/tests/test_build.py9
4 files changed, 3 insertions, 19 deletions
diff --git a/.gitignore b/.gitignore
index 19bc570..84cb76a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -27,7 +27,6 @@ site-packages/
zookeeper/
.coverage
.idea
-.pip_cache
.project
.pydevproject
.tox
diff --git a/.travis.yml b/.travis.yml
index 4feeb07..748dd76 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -4,8 +4,8 @@ addons:
packages:
- libevent-dev
cache:
+ pip: true
directories:
- - "$HOME/.cache/pip"
- zookeeper
language: python
python:
diff --git a/Makefile b/Makefile
index a47902a..61fbc41 100644
--- a/Makefile
+++ b/Makefile
@@ -1,15 +1,10 @@
HERE = $(shell pwd)
BIN = $(HERE)/bin
PYTHON = $(BIN)/python
-PIP_DOWNLOAD_CACHE ?= $(HERE)/.pip_cache
INSTALL = $(BIN)/pip install
-ifneq ($(TRAVIS), true)
- INSTALL += --download-cache $(PIP_DOWNLOAD_CACHE)
-endif
TOX_VENV ?= py27
BUILD_DIRS = bin build include lib lib64 man share
-GEVENT_VERSION ?= 1.0.1
PYTHON_EXE = $(shell [ -f $(PYTHON) ] && echo $(PYTHON) || echo python)
PYPY = $(shell $(PYTHON_EXE) -c "import sys; print(getattr(sys, 'pypy_version_info', False) and 'yes' or 'no')")
TRAVIS ?= false
@@ -18,9 +13,9 @@ TRAVIS_PYTHON_VERSION ?= $(shell $(PYTHON_EXE) -c "import sys; print('.'.join([s
GREENLET_SUPPORTED = yes
ifeq ($(findstring 3.,$(TRAVIS_PYTHON_VERSION)), 3.)
GREENLET_SUPPORTED = no
- VENV_CMD = python -m venv .
+ VENV_CMD = $(PYTHON_EXE) -m venv .
else
- VENV_CMD = python -m virtualenv .
+ VENV_CMD = $(PYTHON_EXE) -m virtualenv .
endif
ifeq ($(PYPY),yes)
GREENLET_SUPPORTED = no
@@ -37,7 +32,6 @@ build: $(PYTHON)
ifeq ($(GREENLET_SUPPORTED),yes)
$(INSTALL) -U -r requirements_eventlet.txt
$(INSTALL) -U -r requirements_gevent.txt
- $(INSTALL) -f https://github.com/surfly/gevent/releases gevent==$(GEVENT_VERSION)
endif
ifneq ($(TRAVIS), true)
$(INSTALL) -U -r requirements_sphinx.txt
diff --git a/kazoo/tests/test_build.py b/kazoo/tests/test_build.py
index 0f778a6..b8e4bbc 100644
--- a/kazoo/tests/test_build.py
+++ b/kazoo/tests/test_build.py
@@ -12,15 +12,6 @@ class TestBuildEnvironment(KazooTestCase):
if not os.environ.get('TRAVIS'):
raise SkipTest('Only run build config tests on Travis.')
- def test_gevent_version(self):
- try:
- import gevent
- except ImportError:
- raise SkipTest('gevent not available.')
- env_version = os.environ.get('GEVENT_VERSION')
- if env_version:
- self.assertEqual(env_version, gevent.__version__)
-
def test_zookeeper_version(self):
server_version = self.client.server_version()
server_version = '.'.join([str(i) for i in server_version])