summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Schlichting <hanno@hannosch.eu>2017-07-24 21:07:41 +0200
committerHanno Schlichting <hanno@hannosch.eu>2017-07-24 21:36:44 +0200
commit4ebeb1550b8e1adc9fe278efd07b2ff4694b011f (patch)
tree49d2dc8c06dca0cd4f40627c8be741ff99e8f7f2
parenteaf91f09321a1086b0f869e965ac28c9e91800ba (diff)
downloadkazoo-4ebeb1550b8e1adc9fe278efd07b2ff4694b011f.tar.gz
Remove deprecated `pip --download-cache` option.
-rw-r--r--.gitignore1
-rw-r--r--.travis.yml2
-rw-r--r--Makefile4
3 files changed, 1 insertions, 6 deletions
diff --git a/.gitignore b/.gitignore
index 19bc570..84cb76a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -27,7 +27,6 @@ site-packages/
zookeeper/
.coverage
.idea
-.pip_cache
.project
.pydevproject
.tox
diff --git a/.travis.yml b/.travis.yml
index 4feeb07..748dd76 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -4,8 +4,8 @@ addons:
packages:
- libevent-dev
cache:
+ pip: true
directories:
- - "$HOME/.cache/pip"
- zookeeper
language: python
python:
diff --git a/Makefile b/Makefile
index 2b87315..677c366 100644
--- a/Makefile
+++ b/Makefile
@@ -1,11 +1,7 @@
HERE = $(shell pwd)
BIN = $(HERE)/bin
PYTHON = $(BIN)/python
-PIP_DOWNLOAD_CACHE ?= $(HERE)/.pip_cache
INSTALL = $(BIN)/pip install
-ifneq ($(TRAVIS), true)
- INSTALL += --download-cache $(PIP_DOWNLOAD_CACHE)
-endif
TOX_VENV ?= py27
BUILD_DIRS = bin build include lib lib64 man share